summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-16 07:16:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-16 07:16:52 +0200
commitfd5633eaf8a0950ec975cc0577f4dbab2d902aa5 (patch)
tree05b7bfa36f816ddc583de6ad3c37e4ba5cfa1b42 /dev-python/fastjsonschema
parentdev-python/django-crispy-forms: Bump to 2.2 (diff)
downloadgentoo-fd5633eaf8a0950ec975cc0577f4dbab2d902aa5.tar.gz
gentoo-fd5633eaf8a0950ec975cc0577f4dbab2d902aa5.tar.bz2
gentoo-fd5633eaf8a0950ec975cc0577f4dbab2d902aa5.zip
dev-python/fastjsonschema: Bump to 2.20.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fastjsonschema')
-rw-r--r--dev-python/fastjsonschema/Manifest1
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.20.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index 294e7ffd3d6f..79bedb09a3b0 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1 +1,2 @@
DIST fastjsonschema-2.19.1.tar.gz 372732 BLAKE2B f028e027483e02969c4d750a888659add9dd7f661776ab42242f74492272267b93a2248cdc50b78389091cc1a1fd7661abbf377d81edf73df35ed1e222be7328 SHA512 b276788ebe1d3a6bc5d1463c2a4940fbe5c9e0a7919c813b78f385faa406527cac34d4042e6a69e0ca1631f3e5ed0bc351e13d9d1e245132a1607e010a5a2346
+DIST fastjsonschema-2.20.0.tar.gz 373056 BLAKE2B 99e80a6aa05aef421c5d95149f5f40f0a732bd686888f32067295c19d9c1d7569bf628d06b59bbeb68ea302e06de700b05c27e7a44e018b213e0c1a7f4dc1304 SHA512 7881937a02c7487d1dfd7499dbe85e8f8e359b9686673f32491d93cef1d7a949df5309b0d4a5cc525a7d9c8269568bc34e9d072ec1a49e44d5becbf8718b250d
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.20.0.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.20.0.ebuild
new file mode 100644
index 000000000000..84565f715777
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.20.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="
+ https://github.com/horejsek/python-fastjsonschema/
+ https://pypi.org/project/fastjsonschema/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/benchmarks
+)