summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-11-09 22:46:40 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-11-09 22:53:57 +0200
commit73011b6c69b6cc5b57f665f40ab59796d6718289 (patch)
tree4756061bb315e72dd5cd48853b38927991720b64 /dev-python/colour
parentmedia-radio/fldigi: add 4.2.03 (diff)
downloadgentoo-73011b6c69b6cc5b57f665f40ab59796d6718289.tar.gz
gentoo-73011b6c69b6cc5b57f665f40ab59796d6718289.tar.bz2
gentoo-73011b6c69b6cc5b57f665f40ab59796d6718289.zip
dev-python/colour: enable tests
While hidden, the tests are doctests inside the python module. So if we pass `--doctest-modules` to pytest, it will trigger them. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/colour')
-rw-r--r--dev-python/colour/colour-0.1.5.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/colour/colour-0.1.5.ebuild b/dev-python/colour/colour-0.1.5.ebuild
index d2b88e2f4779..f75cd5a01399 100644
--- a/dev-python/colour/colour-0.1.5.ebuild
+++ b/dev-python/colour/colour-0.1.5.ebuild
@@ -17,8 +17,14 @@ SLOT="0"
PATCHES=( "${FILESDIR}"/${PN}-setup.patch )
+distutils_enable_tests pytest
+
src_prepare() {
rm setup.cfg || die
distutils-r1_src_prepare
}
+
+python_test() {
+ epytest --doctest-modules
+}