summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-10 11:21:11 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-10 11:21:18 +0100
commit070bb83ca4a64ee8f3babd9f1f0afe863fa2e88b (patch)
treeafffa41e709d9cc7c5aaad1cdef42c3f3dad6d90 /dev-python/click-plugins
parentmedia-gfx/netgen: new package, add 6.2.2204 (diff)
downloadgentoo-070bb83ca4a64ee8f3babd9f1f0afe863fa2e88b.tar.gz
gentoo-070bb83ca4a64ee8f3babd9f1f0afe863fa2e88b.tar.bz2
gentoo-070bb83ca4a64ee8f3babd9f1f0afe863fa2e88b.zip
dev-python/click-plugins: update EAPI 7 -> 8, pep517, enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/click-plugins')
-rw-r--r--dev-python/click-plugins/click-plugins-1.1.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/click-plugins/click-plugins-1.1.1-r1.ebuild b/dev-python/click-plugins/click-plugins-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..67293946200d
--- /dev/null
+++ b/dev-python/click-plugins/click-plugins-1.1.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Module for click to enable registering CLI commands via setuptools entry-points"
+HOMEPAGE="https://github.com/click-contrib/click-plugins"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+SLOT="0"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
+
+distutils_enable_tests pytest