summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-07-06 17:12:46 +0200
committerAlexis Ballier <aballier@gentoo.org>2022-07-06 17:14:04 +0200
commit598819d1a34cb5d100405d7168413fd0ede90ae9 (patch)
treef52baa5ae104f661ba5362f52d807aa9e87e9601 /dev-python/catkin_pkg
parentsci-mathematics/octave: Stabilize 6.4.0-r3 arm64, #854489 (diff)
downloadgentoo-598819d1a34cb5d100405d7168413fd0ede90ae9.tar.gz
gentoo-598819d1a34cb5d100405d7168413fd0ede90ae9.tar.bz2
gentoo-598819d1a34cb5d100405d7168413fd0ede90ae9.zip
dev-python/catkin_pkg: bump to 0.5.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/catkin_pkg')
-rw-r--r--dev-python/catkin_pkg/Manifest1
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.5.2.ebuild45
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-9999.ebuild5
-rw-r--r--dev-python/catkin_pkg/files/infinite_loop5.patch27
4 files changed, 75 insertions, 3 deletions
diff --git a/dev-python/catkin_pkg/Manifest b/dev-python/catkin_pkg/Manifest
index c7f66fef7438..ad5ec33456df 100644
--- a/dev-python/catkin_pkg/Manifest
+++ b/dev-python/catkin_pkg/Manifest
@@ -1 +1,2 @@
DIST catkin_pkg-0.4.24-gh.tar.gz 65113 BLAKE2B 554848e5e34a663b29246ec1109f228361cbb010d76d54e0b27107189382843e90babf24f8660dce4063324f78dff87286e31f5f1bb7db10aaa86e056c23de2d SHA512 7c746917876d5a9d8be6f187fc3d75e322ab158ff9fd1b9c661e0802504b188c59d47ad42320613e3aff26b83a6f239bb3dec5d0ab16dadd2ff1e26f73288e61
+DIST catkin_pkg-0.5.2-gh.tar.gz 67596 BLAKE2B aec34c6f54926dee02034d542741affe9cb662b06b354062088bec1fec25381f036d59af5fa52153ba1ce1c91fdf8bb9d1484475df8a63268ca474a7acd5f285 SHA512 40e7e3839017ad430ee36dccf87a90727e5efd92e6c605cdba3e9f8850b71a6a80da79bd8760d94e356dadebdd842c8a3f8b530782fb75503d3e620add79be4a
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.5.2.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.5.2.ebuild
new file mode 100644
index 000000000000..ae7ac37cda94
--- /dev/null
+++ b/dev-python/catkin_pkg/catkin_pkg-0.5.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="https://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ !<dev-util/catkin-0.7.14"
+BDEPEND="
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/catkin_prefix2.patch"
+ "${FILESDIR}/ros_packages.patch"
+ "${FILESDIR}/infinite_loop5.patch"
+)
+
+distutils_enable_tests nose
diff --git a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
index 79e5eb6b91bf..ae7ac37cda94 100644
--- a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -39,8 +39,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/catkin_prefix2.patch"
"${FILESDIR}/ros_packages.patch"
- "${FILESDIR}/infinite_loop4.patch"
- "${FILESDIR}/summary_single_line.patch"
+ "${FILESDIR}/infinite_loop5.patch"
)
distutils_enable_tests nose
diff --git a/dev-python/catkin_pkg/files/infinite_loop5.patch b/dev-python/catkin_pkg/files/infinite_loop5.patch
new file mode 100644
index 000000000000..7f88da41a27d
--- /dev/null
+++ b/dev-python/catkin_pkg/files/infinite_loop5.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/show_bug.cgi?id=612860
+By Tim Rakowski
+We os.walk /usr with followlinks=True, but at least nodejs contains a "recursive" link in /usr/include/node
+
+Index: catkin_pkg-0.5.2/src/catkin_pkg/packages.py
+===================================================================
+--- catkin_pkg-0.5.2.orig/src/catkin_pkg/packages.py
++++ catkin_pkg-0.5.2/src/catkin_pkg/packages.py
+@@ -61,7 +61,9 @@ def find_package_paths(basepath, exclude
+ """
+ paths = []
+ real_exclude_paths = [os.path.realpath(p) for p in exclude_paths] if exclude_paths is not None else []
++ visited = set()
+ for dirpath, dirnames, filenames in os.walk(basepath, followlinks=True):
++ visited.add(dirpath)
+ if set(dirnames + filenames) & ignore_markers or \
+ os.path.realpath(dirpath) in real_exclude_paths or \
+ (exclude_subspaces and '.catkin' in filenames):
+@@ -72,7 +74,7 @@ def find_package_paths(basepath, exclude
+ del dirnames[:]
+ continue
+ # filter out hidden directories in-place
+- dirnames[:] = [d for d in dirnames if not d.startswith('.')]
++ dirnames[:] = [d for d in dirnames if not d.startswith('.') and not os.path.realpath(os.path.join(dirpath, d)) in visited]
+ return paths
+
+