summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-13 12:56:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-13 16:07:02 +0200
commit9fed31691229b14a129c17e37f50e6d5c84819c7 (patch)
treeac982af4f0f97816a9835c2b25ac46569a846d27 /dev-python/catkin_pkg/catkin_pkg-0.4.20.ebuild
parentdev-python/pyaudio: add support for Python 3.7 and 3.8 (diff)
downloadgentoo-9fed31691229b14a129c17e37f50e6d5c84819c7.tar.gz
gentoo-9fed31691229b14a129c17e37f50e6d5c84819c7.tar.bz2
gentoo-9fed31691229b14a129c17e37f50e6d5c84819c7.zip
dev-python/catkin_pkg: Bump to 0.4.20.
Add python 3.8 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/catkin_pkg/catkin_pkg-0.4.20.ebuild')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.4.20.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.4.20.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.4.20.ebuild
new file mode 100644
index 000000000000..622966856b37
--- /dev/null
+++ b/dev-python/catkin_pkg/catkin_pkg-0.4.20.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8} pypy3 )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND} ${BDEPEND}
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${RDEPEND}
+ !<dev-util/catkin-0.7.14"
+PATCHES=(
+ "${FILESDIR}/catkin_prefix2.patch"
+ "${FILESDIR}/ros_packages.patch"
+ "${FILESDIR}/infinite_loop4.patch"
+)
+
+python_test() {
+ nosetests -s --tests test || die
+}