summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-21 06:21:59 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-21 07:28:18 +0200
commit515565bf0555b702bb5261bcdf0cd92e105c7b9b (patch)
treefe9e5cc604b6f813f7a6d0a04fb7872e04a2c464 /dev-python/botocore
parentdev-python/aesara: Bump to 2.9.2 (diff)
downloadgentoo-515565bf0555b702bb5261bcdf0cd92e105c7b9b.tar.gz
gentoo-515565bf0555b702bb5261bcdf0cd92e105c7b9b.tar.bz2
gentoo-515565bf0555b702bb5261bcdf0cd92e105c7b9b.zip
dev-python/botocore: Bump to 1.31.52
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.31.52.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 983a9dc68645..e8280f82f712 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -14,3 +14,4 @@ DIST botocore-1.31.48.gh.tar.gz 11946450 BLAKE2B 5393125dcc346182ea81ebebeb181cc
DIST botocore-1.31.49.gh.tar.gz 11946203 BLAKE2B 3b3026f0861705cc3467391c673d2e2f8e63af1a2e52b63cad21e5f75bf31f5970a2a5f5a959dc8dcd1be6c3ad67ed10642c79a7d41a24e15e983096818e8197 SHA512 8e1cb12ff7455bbf62c5cf54c2bc1b8f48484ebc6e95b4e061d5bc6388a4ecd3ff4152a1d9aab5cbee84d872d59417cfb1cecb6fd281f1f8dd9e3e7e04cc782d
DIST botocore-1.31.50.gh.tar.gz 11946516 BLAKE2B 84f9eadc8c2867286d098e9f429c097bcd58b02898779ff3b4ee390af91c3949675b43ea954e2c393b897f97941326fbf0a9d477df015f2406e00f77629e79ed SHA512 53157bb104f10e711b409a31ede6ccce6be7ae013474ca42248db0afd7dcaae0f9f5ec0637a9c337c2691de79a0df743fc3bde69c16ef746b6274d4bd252bbff
DIST botocore-1.31.51.gh.tar.gz 11946778 BLAKE2B 59dddb63a9d6d4944498d34af28bc6325a4867986fd7240bc4c1937572574eccc8563ddcb768f2053c85b4d9b6fc73e670f453b588519dae4a526b0ee54db17c SHA512 a7ba6922fc1cb14da7611a316a6ad7c846b4521829b55b6896365f0f2a6563bf3bcf456699d9d94febc4917ce9d23105542190eff6c97dc7a1d027d95057c655
+DIST botocore-1.31.52.gh.tar.gz 11951798 BLAKE2B cdb703fac2244c64ebaaf2b869a48121c6145f54ab9804d172b3ea03f2cffc23b5db72ea0728a0c27c8116d939a5f8413124c2c4026e68c27427f0c214b15ea1 SHA512 775616106aa1013f884c7513b2b445c9e138c21a30e9b7f3b5a17a364d8d7abee4248ef0962e8617641de4e7e0f924c61bbb98c6498ef2096aae2d0cdaff0996
diff --git a/dev-python/botocore/botocore-1.31.52.ebuild b/dev-python/botocore/botocore-1.31.52.ebuild
new file mode 100644
index 000000000000..7cacb5c3f634
--- /dev/null
+++ b/dev-python/botocore/botocore-1.31.52.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit} -p xdist -n "$(makeopts_jobs)"
+}