summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-python/blaze
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/blaze')
-rw-r--r--dev-python/blaze/blaze-0.10.2.ebuild1
-rw-r--r--dev-python/blaze/blaze-0.11.3.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/blaze/blaze-0.10.2.ebuild b/dev-python/blaze/blaze-0.10.2.ebuild
index e91899ce33b6..31109ca7fb71 100644
--- a/dev-python/blaze/blaze-0.10.2.ebuild
+++ b/dev-python/blaze/blaze-0.10.2.ebuild
@@ -18,6 +18,7 @@ KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
# Currently doc build fails, reason now, attempt to import mystery modules in datashape
# Leaving doc build content in case this is fixed
IUSE="examples test"
+RESTRICT="!test? ( test )"
# pyspark appears an optional dep not in portage. pyskit appears to be dropped
# some packages including pyparsing appear required despite their absence from requirements.txt
diff --git a/dev-python/blaze/blaze-0.11.3.ebuild b/dev-python/blaze/blaze-0.11.3.ebuild
index b63501d2bf94..482f87e156c2 100644
--- a/dev-python/blaze/blaze-0.11.3.ebuild
+++ b/dev-python/blaze/blaze-0.11.3.ebuild
@@ -16,6 +16,7 @@ SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="examples test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/bcolz[${PYTHON_USEDEP}]