summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-15 09:16:07 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-15 13:32:42 +0200
commit56ff4cd841797db0533772957e830b4ce51b7c2d (patch)
tree765db0245f6e892c3ad130e93e0f706444766ed9 /dev-python/Babel
parentdev-python/outcome: Bump to 1.2.0 (diff)
downloadgentoo-56ff4cd841797db0533772957e830b4ce51b7c2d.tar.gz
gentoo-56ff4cd841797db0533772957e830b4ce51b7c2d.tar.bz2
gentoo-56ff4cd841797db0533772957e830b4ce51b7c2d.zip
dev-python/Babel: Bump to 2.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-2.10.2.ebuild54
-rw-r--r--dev-python/Babel/Manifest2
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/Babel/Babel-2.10.2.ebuild b/dev-python/Babel/Babel-2.10.2.ebuild
new file mode 100644
index 000000000000..923320a61991
--- /dev/null
+++ b/dev-python/Babel/Babel-2.10.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+# see scripts/download_import_cldr.py
+CLDR_PV=41.0
+DESCRIPTION="Collection of tools for internationalizing Python applications"
+HOMEPAGE="
+ https://babel.pocoo.org/
+ https://pypi.org/project/Babel/
+ https://github.com/python-babel/babel/
+"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://unicode.org/Public/cldr/${CLDR_PV%.*}/cldr-common-${CLDR_PV}.zip
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ app-arch/unzip
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_configure_all() {
+ rm babel/locale-data/*.dat || die
+ rm babel/global.dat || die
+ "${EPYTHON}" scripts/import_cldr.py "${WORKDIR}"/common || die
+}
+
+python_test() {
+ local -x TZ=UTC
+ epytest
+}
diff --git a/dev-python/Babel/Manifest b/dev-python/Babel/Manifest
index 052c66a72536..048ea62b416b 100644
--- a/dev-python/Babel/Manifest
+++ b/dev-python/Babel/Manifest
@@ -1 +1,3 @@
DIST Babel-2.10.1.tar.gz 9342917 BLAKE2B fe9f4cff416a57b4964481afcf9cf154b3d9e2c0c88b2b97786cbede1cb068f9637a2168a819dd94770ce3a5836ee8096b2fe7131d2dff16eb0a31a924b9fae1 SHA512 d6f8876bc47d2ad88277f5a9512abb177518b79d4f477cdba11d1cd1af8fb92bfd033c2c05c7a6c32dbd087a28189288f8ac80f9b654027b3e026a06c4ade127
+DIST Babel-2.10.2.tar.gz 9346156 BLAKE2B f6d8c3ccc00c5384c52d98d9939e58a2ec6f16dafd89b5ae5b5a302db16ff1d773d5843d1aca6a4cede859aa7dfa33ebbe4c49bd06c2720e0aa916a097d26fdd SHA512 d292cd26e8eeeed699a8307540a10bb5521a118940928eecf56622d22c01fd566b1c22cd86b33d92c0c1fe3eaaf8c0d634636d288f74f18cb297137de6fdc842
+DIST cldr-common-41.0.zip 29364494 BLAKE2B 1960e860017c3e5f31d935d66a1ff551720975dca0af459adc72b8dc54100938fbd2d2ef00eb457f3fd04d4f1e90a4783229c350b125029dcda5c1e6903f9a54 SHA512 c64f3338e292962817b043dd11e9c47f533c9b70d432f83e80654e20f4937c72b37e66a60485df43f734b1ff94ebf0452547a063076917889303c9653b4d6ce5