summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-08 09:53:49 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-08 13:28:10 -0500
commitb22dfa066e20f315d1436d9c8adc1126afc07f26 (patch)
treebf88f3f3fd3017448c42b215560c46e6a1321039 /dev-php/xcache
parentkde-apps/ffmpegthumbs: Drop slot 4 (diff)
downloadgentoo-b22dfa066e20f315d1436d9c8adc1126afc07f26.tar.gz
gentoo-b22dfa066e20f315d1436d9c8adc1126afc07f26.tar.bz2
gentoo-b22dfa066e20f315d1436d9c8adc1126afc07f26.zip
dev-php/xcache: Drop old
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php/xcache')
-rw-r--r--dev-php/xcache/xcache-3.2.0-r1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-php/xcache/xcache-3.2.0-r1.ebuild b/dev-php/xcache/xcache-3.2.0-r1.ebuild
deleted file mode 100644
index f6cd14d26263..000000000000
--- a/dev-php/xcache/xcache-3.2.0-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PHP_EXT_NAME="xcache"
-PHP_EXT_SAPIS="apache2 cgi fpm"
-USE_PHP="php5-5 php5-6"
-
-inherit php-ext-source-r3 confutils
-
-DESCRIPTION="A fast and stable PHP opcode cacher"
-HOMEPAGE="http://xcache.lighttpd.net/"
-SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="coverage"
-
-# make test would just run php's test and as such need the full php source
-RESTRICT="test"
-
-DEPEND="
- !dev-php/eaccelerator
- !dev-php/pecl-apc
- virtual/httpd-php:*
- php_targets_php5-5? ( !dev-lang/php:5.5[opcache] )
-"
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS )
-
-src_configure() {
- PHP_EXT_ECONF_ARGS=(
- --enable-xcache=shared
- --enable-xcache-constant \
- --enable-xcache-optimizer \
- $(use_enable coverage xcache-coverager) \
- --enable-xcache-assembler \
- --enable-xcache-encoder \
- --enable-xcache-decoder )
-
- php-ext-source-r3_src_configure
-}
-
-src_install() {
- php-ext-source-r3_src_install
-
- insinto "${PHP_EXT_SHARED_DIR}"
- doins lib/Decompiler.class.php
-
- # Install the admin interface somewhere where it can be
- # copied/symlinked into a document root.
- insinto "/usr/share/${PN}"
- doins -r htdocs
-}
-
-pkg_postinst() {
- elog "The lib/Decompiler.class.php file shipped with this release"
- elog "was installed into ${PHP_EXT_SHARED_DIR}. The htdocs/ admin"
- elog "interface directory can be found under ${EPREFIX}/usr/share/${PN}."
-}