summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-18 22:53:04 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-18 22:53:28 +1300
commit6a9b846eb4eacb48b3658715f0f78a4bdc365978 (patch)
treeb5c3e9b39091e978e75abb940c3556f8844bfea6 /dev-perl/Unicode-LineBreak
parentsys-apps/cciss_vol_status: Drop old (diff)
downloadgentoo-6a9b846eb4eacb48b3658715f0f78a4bdc365978.tar.gz
gentoo-6a9b846eb4eacb48b3658715f0f78a4bdc365978.tar.bz2
gentoo-6a9b846eb4eacb48b3658715f0f78a4bdc365978.zip
dev-perl/Unicode-LineBreak: Fix tests for '.' in @INC bug #614538
- EAPI6 - Fir for '.' in @INC bug #614538 - Kill unwanted POD author tests - Enable parallel tests Bug: https://bugs.gentoo.org/614538 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Unicode-LineBreak')
-rw-r--r--dev-perl/Unicode-LineBreak/Unicode-LineBreak-2017.4.0-r1.ebuild21
-rw-r--r--dev-perl/Unicode-LineBreak/files/Unicode-LineBreak-2017.004-dotinc.patch232
-rw-r--r--dev-perl/Unicode-LineBreak/metadata.xml2
3 files changed, 254 insertions, 1 deletions
diff --git a/dev-perl/Unicode-LineBreak/Unicode-LineBreak-2017.4.0-r1.ebuild b/dev-perl/Unicode-LineBreak/Unicode-LineBreak-2017.4.0-r1.ebuild
new file mode 100644
index 000000000000..1b10cd0a7347
--- /dev/null
+++ b/dev-perl/Unicode-LineBreak/Unicode-LineBreak-2017.4.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=NEZUMI
+DIST_VERSION=2017.004
+
+inherit perl-module
+
+DESCRIPTION="UAX #14 Unicode Line Breaking Algorithm"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+RDEPEND="dev-perl/MIME-Charset
+ virtual/perl-Encode"
+DEPEND="${RDEPEND}"
+PATCHES=("${FILESDIR}/${PN}-2017.004-dotinc.patch")
+PERL_RM_FILES=("t/pod.t")
diff --git a/dev-perl/Unicode-LineBreak/files/Unicode-LineBreak-2017.004-dotinc.patch b/dev-perl/Unicode-LineBreak/files/Unicode-LineBreak-2017.004-dotinc.patch
new file mode 100644
index 000000000000..3a9b808f4669
--- /dev/null
+++ b/dev-perl/Unicode-LineBreak/files/Unicode-LineBreak-2017.004-dotinc.patch
@@ -0,0 +1,232 @@
+From fd36408d8e59381c0ea217166a244222adbd5ec9 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 18 Mar 2018 22:02:48 +1300
+Subject: Fix tests for '.' in @INC removal on Perl 5.26+
+
+---
+ t/01break.t | 2 +-
+ t/02hangul.t | 2 +-
+ t/03ns.t | 2 +-
+ t/04fold.t | 2 +-
+ t/05urgent.t | 2 +-
+ t/06context.t | 2 +-
+ t/07sea.t | 2 +-
+ t/08partial.t | 2 +-
+ t/09uri.t | 2 +-
+ t/11format.t | 2 +-
+ t/12fold2.t | 2 +-
+ t/13flowedsp.t | 2 +-
+ t/14sea_al.t | 2 +-
+ t/15array.t | 2 +-
+ t/16regex.t | 2 +-
+ t/17prop.t | 2 +-
+ t/18currency.t | 2 +-
+ 17 files changed, 17 insertions(+), 17 deletions(-)
+
+diff --git a/t/01break.t b/t/01break.t
+index a7676bc..4d80758 100644
+--- a/t/01break.t
++++ b/t/01break.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 13 }
+
+diff --git a/t/02hangul.t b/t/02hangul.t
+index 5140636..027f418 100644
+--- a/t/02hangul.t
++++ b/t/02hangul.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 2 }
+
+diff --git a/t/03ns.t b/t/03ns.t
+index 8d515dd..43b50f7 100644
+--- a/t/03ns.t
++++ b/t/03ns.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 2 }
+
+diff --git a/t/04fold.t b/t/04fold.t
+index 8eb9624..50287cb 100644
+--- a/t/04fold.t
++++ b/t/04fold.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lf.pl";
++require "./t/lf.pl";
+
+ BEGIN { plan tests => 15 + 2 }
+
+diff --git a/t/05urgent.t b/t/05urgent.t
+index e5f27c7..0ae4c66 100644
+--- a/t/05urgent.t
++++ b/t/05urgent.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 5 }
+
+diff --git a/t/06context.t b/t/06context.t
+index 4de9f4e..e8ac3f7 100644
+--- a/t/06context.t
++++ b/t/06context.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 2 }
+
+diff --git a/t/07sea.t b/t/07sea.t
+index 8446e96..da4d49a 100644
+--- a/t/07sea.t
++++ b/t/07sea.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN {
+ require Unicode::LineBreak;
+diff --git a/t/08partial.t b/t/08partial.t
+index e94f0a0..5baa894 100644
+--- a/t/08partial.t
++++ b/t/08partial.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 15 }
+
+diff --git a/t/09uri.t b/t/09uri.t
+index 333e1cf..edb4d25 100644
+--- a/t/09uri.t
++++ b/t/09uri.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 2 }
+
+diff --git a/t/11format.t b/t/11format.t
+index 62167cc..d4ebd5b 100644
+--- a/t/11format.t
++++ b/t/11format.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 6 }
+
+diff --git a/t/12fold2.t b/t/12fold2.t
+index c9a64ef..d9fd4e8 100644
+--- a/t/12fold2.t
++++ b/t/12fold2.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lf.pl";
++require "./t/lf.pl";
+
+ BEGIN { plan tests => 2 }
+
+diff --git a/t/13flowedsp.t b/t/13flowedsp.t
+index 4454e6b..d4b96b8 100644
+--- a/t/13flowedsp.t
++++ b/t/13flowedsp.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lf.pl";
++require "./t/lf.pl";
+
+ BEGIN { plan tests => 1 }
+
+diff --git a/t/14sea_al.t b/t/14sea_al.t
+index 5a45574..2990333 100644
+--- a/t/14sea_al.t
++++ b/t/14sea_al.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 1 }
+
+diff --git a/t/15array.t b/t/15array.t
+index 5ab75c2..51d79ab 100644
+--- a/t/15array.t
++++ b/t/15array.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 19 }
+
+diff --git a/t/16regex.t b/t/16regex.t
+index 4a7f0db..e85e203 100644
+--- a/t/16regex.t
++++ b/t/16regex.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ my $splitre;
+ BEGIN {
+diff --git a/t/17prop.t b/t/17prop.t
+index 55b9944..7f5b68c 100644
+--- a/t/17prop.t
++++ b/t/17prop.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require 't/lb.pl';
++require './t/lb.pl';
+
+ BEGIN { plan tests => 12 }
+
+diff --git a/t/18currency.t b/t/18currency.t
+index e280ddd..4d6feef 100644
+--- a/t/18currency.t
++++ b/t/18currency.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require 't/lb.pl';
++require './t/lb.pl';
+
+ BEGIN { plan tests => 96 }
+
+--
+2.16.2
+
diff --git a/dev-perl/Unicode-LineBreak/metadata.xml b/dev-perl/Unicode-LineBreak/metadata.xml
index 216aa400bc04..de9136171e5d 100644
--- a/dev-perl/Unicode-LineBreak/metadata.xml
+++ b/dev-perl/Unicode-LineBreak/metadata.xml
@@ -7,8 +7,8 @@
</maintainer>
<upstream>
<remote-id type="cpan">Unicode-LineBreak</remote-id>
+ <remote-id type="cpan-module">Text::LineFold</remote-id>
<remote-id type="cpan-module">Unicode::GCString</remote-id>
<remote-id type="cpan-module">Unicode::LineBreak</remote-id>
- <remote-id type="cpan-module">Text::LineFold</remote-id>
</upstream>
</pkgmetadata>