summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Role-Tiny
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Role-Tiny')
-rw-r--r--dev-perl/Role-Tiny/Manifest2
-rw-r--r--dev-perl/Role-Tiny/Role-Tiny-1.3.2.ebuild27
-rw-r--r--dev-perl/Role-Tiny/Role-Tiny-2.0.0.ebuild28
-rw-r--r--dev-perl/Role-Tiny/metadata.xml10
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-perl/Role-Tiny/Manifest b/dev-perl/Role-Tiny/Manifest
new file mode 100644
index 000000000000..b1df9a7da5fd
--- /dev/null
+++ b/dev-perl/Role-Tiny/Manifest
@@ -0,0 +1,2 @@
+DIST Role-Tiny-1.003002.tar.gz 25518 SHA256 7eded275f400aad4eb3624ab395ab9132e299a46d75a21299e6c95e271643676 SHA512 130f9d961caade61a7d2f077945f008b6196db0eb6ddbcb64093bf39421232c30bc1653821754acea336ec0469ea970b49959dd7bd4b2749ea77ed7a7332c6ca WHIRLPOOL 190106c581255af93a349e1ac6150b14941a5ba30b7f0f10017178af3acba556bb841b25f2636bc1064c1f3d0f05f2d51be78eaa2e68a5516e335e37a3e0b5ee
+DIST Role-Tiny-2.000000.tar.gz 21755 SHA256 a5f461e79d9433745807614c3be94f070375a0d4ed277189752fd0fecfe06091 SHA512 afa256d6a5882e7a466294fb0b24bad31fbb5c28e080cd072e704a05b15b702aabe3deb16deddedc892450345c06e2c5cbf0acbaf66432b3982fd481a92db40f WHIRLPOOL bed78cdaa67ef0f3605b5c5e48bc6756757398d2f1668373b21fc47437f06d05aaae732927b04e41bc6910ec3d0c2f946a330e33424cf9dc5d2e3766f15b6efe
diff --git a/dev-perl/Role-Tiny/Role-Tiny-1.3.2.ebuild b/dev-perl/Role-Tiny/Role-Tiny-1.3.2.ebuild
new file mode 100644
index 000000000000..3f0c4903de9d
--- /dev/null
+++ b/dev-perl/Role-Tiny/Role-Tiny-1.3.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=HAARG
+MODULE_VERSION=1.003002
+inherit perl-module
+
+DESCRIPTION="Roles. Like a nouvelle cuisine portion size slice of Moose"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+DEPEND="
+ test? (
+ >=dev-perl/Test-Fatal-0.003
+ >=virtual/perl-Test-Simple-0.96
+ )
+"
+RDEPEND="
+ !<dev-perl/Moo-0.9.14
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Role-Tiny/Role-Tiny-2.0.0.ebuild b/dev-perl/Role-Tiny/Role-Tiny-2.0.0.ebuild
new file mode 100644
index 000000000000..78f8e4bfed98
--- /dev/null
+++ b/dev-perl/Role-Tiny/Role-Tiny-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=HAARG
+MODULE_VERSION=2.000000
+inherit perl-module
+
+DESCRIPTION="Roles. Like a nouvelle cuisine portion size slice of Moose"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Exporter-5.570.0
+ !<dev-perl/Moo-0.9.14
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Role-Tiny/metadata.xml b/dev-perl/Role-Tiny/metadata.xml
new file mode 100644
index 000000000000..3e397d43e175
--- /dev/null
+++ b/dev-perl/Role-Tiny/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Role-Tiny</remote-id>
+ <remote-id type="cpan-module">Role::Tiny</remote-id>
+ <remote-id type="cpan-module">Role::Tiny::With</remote-id>
+ </upstream>
+</pkgmetadata>