summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-24 19:49:45 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-24 19:49:45 +0100
commit621e8c678667a09e33566e23ef25332bca6b17d2 (patch)
tree99328da410af0c4f08780dcf31d904e34469713b /dev-ml
parentdev-python/imageio: add 2.14.1 (diff)
downloadgentoo-621e8c678667a09e33566e23ef25332bca6b17d2.tar.gz
gentoo-621e8c678667a09e33566e23ef25332bca6b17d2.tar.bz2
gentoo-621e8c678667a09e33566e23ef25332bca6b17d2.zip
dev-ml/ocaml-process: fix build without ocamlopt
Closes: https://bugs.gentoo.org/829086 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild b/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild
index 66969b86741b..de33c2c8fc59 100644
--- a/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild
+++ b/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,10 +20,19 @@ BDEPEND="
test? ( dev-ml/alcotest )
"
+src_compile() {
+ exts=.cma
+ use ocamlopt && exts+=' .cmx .cmxa'
+ export pkgs
+ emake TARGETS=${exts}
+}
+
src_install() {
- findlib_src_install
+ local archive=''
+ use ocamlopt && archive='_build/lib/process.a'
+ findlib_src_install TARGETS=${exts} ARCHIVES=${archives}
}
src_test() {
- emake -j1 test
+ emake -j1 TARGETS=${exts} test
}