summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 17:33:59 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:37 +1100
commit0cea125be769b41873a379a241181788534e2b05 (patch)
treec682ba7bec4ccb74b875f92ad436df918ff8c858 /dev-ml/ppx_hash/ppx_hash-0.14.0.ebuild
parentdev-ml/ppx_fixed_literal: Dependency of dev-ml/ppx_jane (diff)
downloadgentoo-0cea125be769b41873a379a241181788534e2b05.tar.gz
gentoo-0cea125be769b41873a379a241181788534e2b05.tar.bz2
gentoo-0cea125be769b41873a379a241181788534e2b05.zip
dev-ml/ppx_hash: Bump to 0.14.0
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_hash/ppx_hash-0.14.0.ebuild')
-rw-r--r--dev-ml/ppx_hash/ppx_hash-0.14.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/ppx_hash/ppx_hash-0.14.0.ebuild b/dev-ml/ppx_hash/ppx_hash-0.14.0.ebuild
new file mode 100644
index 000000000000..d4e20915192c
--- /dev/null
+++ b/dev-ml/ppx_hash/ppx_hash-0.14.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="PPX rewriter that generates hash functions from type expressions and definitions"
+HOMEPAGE="https://github.com/janestreet/ppx_hash"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:=
+ >=dev-ml/ppx_compare-0.10.0:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/result:=
+ dev-ml/ppxlib:=
+"
+RDEPEND="${DEPEND}"