summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2019-08-16 14:10:05 +0200
committerGuilherme Amadio <amadio@gentoo.org>2019-08-16 16:17:45 +0200
commit98a691a76b53c9cf520827e7eb7fdb2df588356b (patch)
tree5ec4c346e2298f478885f118b09f312e752fb24b /dev-libs/xxhash/xxhash-0.7.1.ebuild
parentdev-php/theseer-tokenizer: Remove HOMEPAGE from SRC_URI; Add RESTRICT (diff)
downloadgentoo-98a691a76b53c9cf520827e7eb7fdb2df588356b.tar.gz
gentoo-98a691a76b53c9cf520827e7eb7fdb2df588356b.tar.bz2
gentoo-98a691a76b53c9cf520827e7eb7fdb2df588356b.zip
dev-libs/xxhash: version bump to 0.7.1
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-libs/xxhash/xxhash-0.7.1.ebuild')
-rw-r--r--dev-libs/xxhash/xxhash-0.7.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/xxhash/xxhash-0.7.1.ebuild b/dev-libs/xxhash/xxhash-0.7.1.ebuild
new file mode 100644
index 000000000000..9f2255c1241b
--- /dev/null
+++ b/dev-libs/xxhash/xxhash-0.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Extremely fast non-cryptographic hash algorithm"
+HOMEPAGE="http://www.xxhash.com"
+SRC_URI="https://github.com/Cyan4973/xxHash/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2+"
+# https://abi-laboratory.pro/tracker/timeline/xxhash
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x64-macos"
+IUSE="static-libs"
+
+S="${WORKDIR}/xxHash-${PV}"
+
+src_compile() {
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+src_install() {
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ MANDIR="${EPREFIX}/usr/share/man/man1" \
+ emake DESTDIR="${D}" install
+
+ if ! use static-libs ; then
+ rm "${ED}"/usr/$(get_libdir)/libxxhash.a || die
+ fi
+}