summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-04 09:15:15 -0800
committerMatt Turner <mattst88@gentoo.org>2020-03-04 11:30:52 -0800
commitb969e4fa572316c09bbf6febcb77da48d1fa2e31 (patch)
treefa3513ef2f8742dce4b2e92e352b0614f7c99dc9 /dev-libs/wayland-protocols
parentsys-libs/llvm-libunwind: Remove 10.0.0rc[12] (diff)
downloadgentoo-b969e4fa572316c09bbf6febcb77da48d1fa2e31.tar.gz
gentoo-b969e4fa572316c09bbf6febcb77da48d1fa2e31.tar.bz2
gentoo-b969e4fa572316c09bbf6febcb77da48d1fa2e31.zip
dev-libs/wayland-protocols: Version bump to 1.19
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.19.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index dc002f3a52f3..96c5ba05c4b5 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1 +1,2 @@
DIST wayland-protocols-1.18.tar.xz 108344 BLAKE2B 7e770bafa364ff96441354246801d1c6cbe561eefe864673610dc2d47e3aa5ac7cd22a2fc2925aa1060a261ed6df8b6b5ef81c33adbeb374170821feeecd651f SHA512 166be44f370a99281da442e7e2c2fc2f3169b61eeaa69263611b4e33847e93d1071f3cc89537597e1252d48d03993ce39c7d65f43b66a23c9b1551f47959e483
+DIST wayland-protocols-1.19.tar.xz 107612 BLAKE2B ff91a7eeca0e43a3e93c927f440253c01751872ace142d874431a347ad652c04d02f36fa08b7e48787d569db9787415eafbd24495a442568b6476332c8935243 SHA512 f09b700a785da0002ca215d2e695461368534c5c961e064ca19b73fe0c72754b3c9d4076cf495d8c907053dbabb2381f6a2bbcef41564071a4c589a8c44ff0fb
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.19.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.19.ebuild
new file mode 100644
index 000000000000..85d20d4e9e31
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.19.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ default
+}