summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-01 07:12:37 +0100
committerSam James <sam@gentoo.org>2023-05-01 07:20:00 +0100
commitdff931088f402a745f72a33e911bc321de3b07eb (patch)
treef27b4a9666c47b3f40837e90ff23a6d53f3dcb6a /dev-libs/libxml2/libxml2-9999.ebuild
parentdev-util/systemtap: Stabilize 4.8 sparc, #904650 (diff)
downloadgentoo-dff931088f402a745f72a33e911bc321de3b07eb.tar.gz
gentoo-dff931088f402a745f72a33e911bc321de3b07eb.tar.bz2
gentoo-dff931088f402a745f72a33e911bc321de3b07eb.zip
dev-libs/libxml2: refresh live ebuild
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libxml2/libxml2-9999.ebuild')
-rw-r--r--dev-libs/libxml2/libxml2-9999.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/dev-libs/libxml2/libxml2-9999.ebuild b/dev-libs/libxml2/libxml2-9999.ebuild
index 007c90de1cfa..39232fe55055 100644
--- a/dev-libs/libxml2/libxml2-9999.ebuild
+++ b/dev-libs/libxml2/libxml2-9999.ebuild
@@ -31,7 +31,8 @@ SRC_URI+="
${XSTS_HOME}/${XSTS_NAME_1}/${XSTS_TARBALL_1}
${XSTS_HOME}/${XSTS_NAME_2}/${XSTS_TARBALL_2}
https://www.w3.org/XML/Test/${XMLCONF_TARBALL}
- )"
+ )
+"
S="${WORKDIR}/${PN}-${PV%_rc*}"
LICENSE="MIT"
@@ -40,11 +41,13 @@ IUSE="debug examples +ftp icu lzma +python readline static-libs test"
RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND=">=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}]
+RDEPEND="
+ >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}]
icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
lzma? ( >=app-arch/xz-utils-5.0.5-r1:=[${MULTILIB_USEDEP}] )
python? ( ${PYTHON_DEPS} )
- readline? ( sys-libs/readline:= )"
+ readline? ( sys-libs/readline:= )
+"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
@@ -56,8 +59,6 @@ MULTILIB_CHOST_TOOLS=(
/usr/bin/xml2-config
)
-DOCS=( NEWS README.md TODO TODO_SCHEMAS python/TODO )
-
src_unpack() {
if [[ ${PV} == 9999 ]] ; then
git-r3_src_unpack
@@ -100,13 +101,6 @@ multilib_src_configure() {
# Filter seemingly problematic CFLAGS (bug #26320)
filter-flags -fprefetch-loop-arrays -funroll-loops
- # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
- # https://github.com/gentoo/gentoo/pull/28355
- # mold needs this too but right now tc-ld-is-mold is also not available
- if tc-ld-is-lld; then
- append-ldflags -Wl,--undefined-version
- fi
-
# Notes:
# The meaning of the 'debug' USE flag does not apply to the --with-debug
# switch (enabling the libxml2 debug module). See bug #100898.