summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-09-06 08:59:09 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-10-05 10:15:53 +0300
commit8ef7e7967be382f393f7e76e098d31ff13e199fc (patch)
tree77f8aaf581bf547cf59721a4ada2d8d2588938a1 /dev-libs/keystone
parentmedia-video/amdgpu-pro-amf: version bump for 22.20.3 (diff)
downloadgentoo-8ef7e7967be382f393f7e76e098d31ff13e199fc.tar.gz
gentoo-8ef7e7967be382f393f7e76e098d31ff13e199fc.tar.bz2
gentoo-8ef7e7967be382f393f7e76e098d31ff13e199fc.zip
dev-libs/keystone: explicitly specify python interpreter for cmake
Closes: https://bugs.gentoo.org/867631 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/27161 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/keystone')
-rw-r--r--dev-libs/keystone/keystone-0.9.2-r1.ebuild5
-rw-r--r--dev-libs/keystone/keystone-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-libs/keystone/keystone-0.9.2-r1.ebuild b/dev-libs/keystone/keystone-0.9.2-r1.ebuild
index 68f71673a12f..a6f8dcdd8897 100644
--- a/dev-libs/keystone/keystone-0.9.2-r1.ebuild
+++ b/dev-libs/keystone/keystone-0.9.2-r1.ebuild
@@ -56,6 +56,10 @@ wrap_python() {
fi
}
+pkg_setup() {
+ python_setup
+}
+
src_prepare() {
default
@@ -73,6 +77,7 @@ src_configure() {
-DBUILD_SHARED_LIBS=ON
-DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
-DLLVM_HOST_TRIPLE="${CHOST}"
+ -DPYTHON_EXECUTABLE="${PYTHON}"
)
cmake_src_configure
diff --git a/dev-libs/keystone/keystone-9999.ebuild b/dev-libs/keystone/keystone-9999.ebuild
index 68f71673a12f..a6f8dcdd8897 100644
--- a/dev-libs/keystone/keystone-9999.ebuild
+++ b/dev-libs/keystone/keystone-9999.ebuild
@@ -56,6 +56,10 @@ wrap_python() {
fi
}
+pkg_setup() {
+ python_setup
+}
+
src_prepare() {
default
@@ -73,6 +77,7 @@ src_configure() {
-DBUILD_SHARED_LIBS=ON
-DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
-DLLVM_HOST_TRIPLE="${CHOST}"
+ -DPYTHON_EXECUTABLE="${PYTHON}"
)
cmake_src_configure