summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-08-27 18:47:20 +0200
committerSam James <sam@gentoo.org>2023-08-28 05:03:46 +0100
commitf8ca69dcc50e60f841b3288e662a388800f6fd58 (patch)
tree7fe332cf4a5a675f745f4bfb5f6418030e648222 /dev-libs/capstone
parentmedia-gfx/gthumb: Version bump to 3.12.3 (diff)
downloadgentoo-f8ca69dcc50e60f841b3288e662a388800f6fd58.tar.gz
gentoo-f8ca69dcc50e60f841b3288e662a388800f6fd58.tar.bz2
gentoo-f8ca69dcc50e60f841b3288e662a388800f6fd58.zip
dev-libs/capstone: don't add -Werror to compiler options
Closes: https://bugs.gentoo.org/911481 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/32478 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/capstone')
-rw-r--r--dev-libs/capstone/capstone-9999.ebuild7
-rw-r--r--dev-libs/capstone/files/capstone-9999-werror.patch13
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-libs/capstone/capstone-9999.ebuild b/dev-libs/capstone/capstone-9999.ebuild
index fd6e6133cc4f..6d46a0133be7 100644
--- a/dev-libs/capstone/capstone-9999.ebuild
+++ b/dev-libs/capstone/capstone-9999.ebuild
@@ -35,6 +35,13 @@ DEPEND="${RDEPEND}
BDEPEND="${DISTUTILS_DEPS}"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+PATCHES=(
+ # Currently "-Werror" is only added in the `next`-development branch, but
+ # not merged into 5.* releases. Eventually this patch may be needed in
+ # version 5 releas line. See bug #911481.
+ "${FILESDIR}/${P}-werror.patch"
+)
+
distutils_enable_tests setup.py
if [[ ${PV} == *_rc* ]]; then
diff --git a/dev-libs/capstone/files/capstone-9999-werror.patch b/dev-libs/capstone/files/capstone-9999-werror.patch
new file mode 100644
index 000000000000..1ec58fa056a3
--- /dev/null
+++ b/dev-libs/capstone/files/capstone-9999-werror.patch
@@ -0,0 +1,13 @@
+Bug: https://bugs.gentoo.org/911481
+Upstream: https://github.com/capstone-engine/capstone/pull/2114
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,7 +28,7 @@ project(capstone
+ if (MSVC)
+ add_compile_options(/W1 /w14189)
+ else()
+- add_compile_options(-Werror -Wformat -Wmissing-braces -Wunused-function -Warray-bounds -Wunused-variable -Wparentheses -Wint-in-bool-context)
++ add_compile_options(-Wformat -Wmissing-braces -Wunused-function -Warray-bounds -Wunused-variable -Wparentheses -Wint-in-bool-context)
+ endif()
+
+