summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-20 00:57:04 +0000
committerSam James <sam@gentoo.org>2020-09-20 01:01:24 +0000
commit85378120b7f04a8f7008cf625a82be91bc4e6dd6 (patch)
tree1b0492666a00f4525f406d76389b21816410d851 /dev-java
parentdev-java/cpptasks: port to EAPI 7 (diff)
downloadgentoo-85378120b7f04a8f7008cf625a82be91bc4e6dd6.tar.gz
gentoo-85378120b7f04a8f7008cf625a82be91bc4e6dd6.tar.bz2
gentoo-85378120b7f04a8f7008cf625a82be91bc4e6dd6.zip
dev-java/glassfish-persistence: port to EAPI 7
Closes: https://bugs.gentoo.org/740996 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/glassfish-persistence/glassfish-persistence-1.0-r1.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/dev-java/glassfish-persistence/glassfish-persistence-1.0-r1.ebuild b/dev-java/glassfish-persistence/glassfish-persistence-1.0-r1.ebuild
index f7157f5db556..898ef4606059 100644
--- a/dev-java/glassfish-persistence/glassfish-persistence-1.0-r1.ebuild
+++ b/dev-java/glassfish-persistence/glassfish-persistence-1.0-r1.ebuild
@@ -1,34 +1,34 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils java-pkg-2 java-ant-2
+inherit java-pkg-2 java-ant-2
DESCRIPTION="Glassfish implementation of persistence API"
HOMEPAGE="https://glassfish.java.net/"
SRC_URI="http://download.java.net/javaee5/fcs_branch/promoted/source/glassfish-9_0-b48-src.zip"
+S="${WORKDIR}/glassfish"
LICENSE="CDDL"
SLOT="0"
KEYWORDS="amd64 ~ppc64 x86"
-IUSE=""
-
-RDEPEND="
- >=virtual/jre-1.5"
-DEPEND="
- >=virtual/jdk-1.5
- app-arch/unzip"
-
-S="${WORKDIR}/glassfish"
-java_prepare() {
- epatch "${FILESDIR}"/${P}-python2.7-sax-parser.patch #414807
-}
+BDEPEND="app-arch/unzip"
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
EANT_BUILD_XML="persistence-api/build.xml"
EANT_BUILD_TARGET="all"
+PATCHES=(
+ "${FILESDIR}"/${P}-python2.7-sax-parser.patch
+)
+
+src_prepare() {
+ default
+}
+
src_install() {
cd "${WORKDIR}"/publish/glassfish || die
java-pkg_newjar lib/javaee.jar