summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-05-07 18:24:09 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-09 21:13:20 +0200
commit34c46aa4140ea4cd1160d1a06a38408cc33e3b1e (patch)
tree1a04979be1730a8be75f7349920f40c293e60216 /dev-java
parentdev-java/gnu-jaf: update EAPI 6 -> 8 (diff)
downloadgentoo-34c46aa4140ea4cd1160d1a06a38408cc33e3b1e.tar.gz
gentoo-34c46aa4140ea4cd1160d1a06a38408cc33e3b1e.tar.bz2
gentoo-34c46aa4140ea4cd1160d1a06a38408cc33e3b1e.zip
dev-java/relaxng-datatype: update EAPI 6 -> 8
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/25370 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/relaxng-datatype/relaxng-datatype-1.0-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/relaxng-datatype/relaxng-datatype-1.0-r3.ebuild b/dev-java/relaxng-datatype/relaxng-datatype-1.0-r3.ebuild
new file mode 100644
index 000000000000..5886aafc3e3f
--- /dev/null
+++ b/dev-java/relaxng-datatype/relaxng-datatype-1.0-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+MY_PN="relaxngDatatype"
+MY_P="${MY_PN}-${PV}"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Interface between RELAX NG validators and datatype libraries"
+HOMEPAGE="https://relaxng.org/"
+SRC_URI="mirror://sourceforge/relaxng/${MY_P}.zip -> ${P}.zip"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ java-pkg_clean
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ einstalldocs
+}