summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jackrabbit-webdav
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jackrabbit-webdav')
-rw-r--r--dev-java/jackrabbit-webdav/Manifest1
-rw-r--r--dev-java/jackrabbit-webdav/files/jackrabbit-webdav-2.10.1-CSRFUtilTest.java.patch21
-rw-r--r--dev-java/jackrabbit-webdav/files/jackrabbit-webdav-2.10.1-OutputContextImplTest.java.patch16
-rw-r--r--dev-java/jackrabbit-webdav/files/jackrabbit-webdav-2.10.1-build.xml350
-rw-r--r--dev-java/jackrabbit-webdav/jackrabbit-webdav-2.10.1.ebuild66
-rw-r--r--dev-java/jackrabbit-webdav/metadata.xml5
6 files changed, 459 insertions, 0 deletions
diff --git a/dev-java/jackrabbit-webdav/Manifest b/dev-java/jackrabbit-webdav/Manifest
new file mode 100644
index 000000000000..573baf574696
--- /dev/null
+++ b/dev-java/jackrabbit-webdav/Manifest
@@ -0,0 +1 @@
+DIST jackrabbit-2.10.1-src.zip 13437021 SHA256 e83c6046134de10724fa54a500ae4f85c1caf664d29d915688ca9f1efe21f940 SHA512 c371ff941054f3a916f43f7020f0aebd8146422835a75ab2ad9f9f716c4ef0a94b3b962f9b6e4fadef87b9e82e8143b4ece27280714a4eb71a6b0a38c47d48e9 WHIRLPOOL eea73d558c3e814d09f4b873c3eadad68d7265beadb52d723a248a24700f7ef2753caf0a9e0670134ee8dfba775e0faf8f6d45f21a400c0ecf0c9b9309ae0f4f
diff --git a/dev-java/jackrabbit-webdav/files/jackrabbit-webdav-2.10.1-CSRFUtilTest.java.patch b/dev-java/jackrabbit-webdav/files/jackrabbit-webdav-2.10.1-CSRFUtilTest.java.patch
new file mode 100644
index 000000000000..4c1f286339b8
--- /dev/null
+++ b/dev-java/jackrabbit-webdav/files/jackrabbit-webdav-2.10.1-CSRFUtilTest.java.patch
@@ -0,0 +1,21 @@
+--- src/test/java/org/apache/jackrabbit/webdav/util/CSRFUtilTest.java.orig 2015-07-03 09:36:45.804000000 +0000
++++ src/test/java/org/apache/jackrabbit/webdav/util/CSRFUtilTest.java 2015-07-03 09:36:59.498000000 +0000
+@@ -281,6 +281,18 @@
+ public void removeAttribute(String name) {
+
+ }
++ public int getRemotePort() {
++ return 0;
++ }
++ public String getLocalName() {
++ return null;
++ }
++ public String getLocalAddr() {
++ return null;
++ }
++ public int getLocalPort() {
++ return 0;
++ }
+ public Locale getLocale() {
+ return null;
+ }
diff --git a/dev-java/jackrabbit-webdav/files/jackrabbit-webdav-2.10.1-OutputContextImplTest.java.patch b/dev-java/jackrabbit-webdav/files/jackrabbit-webdav-2.10.1-OutputContextImplTest.java.patch
new file mode 100644
index 000000000000..d9a2315f19a1
--- /dev/null
+++ b/dev-java/jackrabbit-webdav/files/jackrabbit-webdav-2.10.1-OutputContextImplTest.java.patch
@@ -0,0 +1,16 @@
+--- src/test/java/org/apache/jackrabbit/webdav/io/OutputContextImplTest.java.orig 2015-07-03 09:26:48.578000000 +0000
++++ src/test/java/org/apache/jackrabbit/webdav/io/OutputContextImplTest.java 2015-07-03 09:27:34.109000000 +0000
+@@ -40,6 +40,13 @@
+ public void setHeader(String name, String value) {
+ assertTrue(Long.parseLong(value) > Integer.MAX_VALUE);
+ }
++ @Override
++ public void setCharacterEncoding(String name) {
++ }
++ @Override
++ public String getContentType() {
++ return null;
++ }
+ };
+
+ OutputContext ctx = new OutputContextImpl(response, null);
diff --git a/dev-java/jackrabbit-webdav/files/jackrabbit-webdav-2.10.1-build.xml b/dev-java/jackrabbit-webdav/files/jackrabbit-webdav-2.10.1-build.xml
new file mode 100644
index 000000000000..3c3a41206421
--- /dev/null
+++ b/dev-java/jackrabbit-webdav/files/jackrabbit-webdav-2.10.1-build.xml
@@ -0,0 +1,350 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/22/15 2:49 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jackrabbit-webdav-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jackrabbit-webdav-2.10.1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/biz/aQute/bndlib/1.43.0/bndlib-1.43.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.6.6/slf4j-api-1.6.6.jar"/>
+ <pathelement location="${maven.repo.local}/javax/servlet/servlet-api/2.3/servlet-api-2.3.jar"/>
+ <pathelement location="${maven.repo.local}/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar"/>
+ <pathelement location="${maven.repo.local}/commons-codec/commons-codec/1.2/commons-codec-1.2.jar"/>
+ <pathelement location="${maven.repo.local}/org/slf4j/jcl-over-slf4j/1.7.4/jcl-over-slf4j-1.7.4.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/biz/aQute/bndlib/1.43.0/bndlib-1.43.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.6.6/slf4j-api-1.6.6.jar"/>
+ <pathelement location="${maven.repo.local}/javax/servlet/servlet-api/2.3/servlet-api-2.3.jar"/>
+ <pathelement location="${maven.repo.local}/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar"/>
+ <pathelement location="${maven.repo.local}/commons-codec/commons-codec/1.2/commons-codec-1.2.jar"/>
+ <pathelement location="${maven.repo.local}/org/slf4j/jcl-over-slf4j/1.7.4/jcl-over-slf4j-1.7.4.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
+ <pathelement location="${maven.repo.local}/ch/qos/logback/logback-classic/1.0.12/logback-classic-1.0.12.jar"/>
+ <pathelement location="${maven.repo.local}/ch/qos/logback/logback-core/1.0.12/logback-core-1.0.12.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/*TestAll.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <!--
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+ -->
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ source="1.6"
+ linksource="false"
+ breakiterator="false">
+ <link href="http://docs.oracle.com/javase/6/docs/api/"/>
+ <link href="http://www.day.com/maven/javax.jcr/javadocs/jcr-2.0/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/biz/aQute/bndlib/1.43.0"/>
+ <get src="http://repository.apache.org/snapshots/biz/aQute/bndlib/1.43.0/bndlib-1.43.0.jar"
+ dest="${maven.repo.local}/biz/aQute/bndlib/1.43.0/bndlib-1.43.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="https://repo.maven.apache.org/maven2/biz/aQute/bndlib/1.43.0/bndlib-1.43.0.jar"
+ dest="${maven.repo.local}/biz/aQute/bndlib/1.43.0/bndlib-1.43.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/slf4j/slf4j-api/1.6.6"/>
+ <get src="http://repository.apache.org/snapshots/org/slf4j/slf4j-api/1.6.6/slf4j-api-1.6.6.jar"
+ dest="${maven.repo.local}/org/slf4j/slf4j-api/1.6.6/slf4j-api-1.6.6.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="https://repo.maven.apache.org/maven2/org/slf4j/slf4j-api/1.6.6/slf4j-api-1.6.6.jar"
+ dest="${maven.repo.local}/org/slf4j/slf4j-api/1.6.6/slf4j-api-1.6.6.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/javax/servlet/servlet-api/2.3"/>
+ <get src="http://repository.apache.org/snapshots/javax/servlet/servlet-api/2.3/servlet-api-2.3.jar"
+ dest="${maven.repo.local}/javax/servlet/servlet-api/2.3/servlet-api-2.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="https://repo.maven.apache.org/maven2/javax/servlet/servlet-api/2.3/servlet-api-2.3.jar"
+ dest="${maven.repo.local}/javax/servlet/servlet-api/2.3/servlet-api-2.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/commons-httpclient/commons-httpclient/3.1"/>
+ <get src="http://repository.apache.org/snapshots/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar"
+ dest="${maven.repo.local}/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="https://repo.maven.apache.org/maven2/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar"
+ dest="${maven.repo.local}/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/commons-codec/commons-codec/1.2"/>
+ <get src="http://repository.apache.org/snapshots/commons-codec/commons-codec/1.2/commons-codec-1.2.jar"
+ dest="${maven.repo.local}/commons-codec/commons-codec/1.2/commons-codec-1.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="https://repo.maven.apache.org/maven2/commons-codec/commons-codec/1.2/commons-codec-1.2.jar"
+ dest="${maven.repo.local}/commons-codec/commons-codec/1.2/commons-codec-1.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/slf4j/jcl-over-slf4j/1.7.4"/>
+ <get src="http://repository.apache.org/snapshots/org/slf4j/jcl-over-slf4j/1.7.4/jcl-over-slf4j-1.7.4.jar"
+ dest="${maven.repo.local}/org/slf4j/jcl-over-slf4j/1.7.4/jcl-over-slf4j-1.7.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="https://repo.maven.apache.org/maven2/org/slf4j/jcl-over-slf4j/1.7.4/jcl-over-slf4j-1.7.4.jar"
+ dest="${maven.repo.local}/org/slf4j/jcl-over-slf4j/1.7.4/jcl-over-slf4j-1.7.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.10"/>
+ <get src="http://repository.apache.org/snapshots/junit/junit/4.10/junit-4.10.jar"
+ dest="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="https://repo.maven.apache.org/maven2/junit/junit/4.10/junit-4.10.jar"
+ dest="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1"/>
+ <get src="http://repository.apache.org/snapshots/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="https://repo.maven.apache.org/maven2/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/ch/qos/logback/logback-classic/1.0.12"/>
+ <get src="http://repository.apache.org/snapshots/ch/qos/logback/logback-classic/1.0.12/logback-classic-1.0.12.jar"
+ dest="${maven.repo.local}/ch/qos/logback/logback-classic/1.0.12/logback-classic-1.0.12.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="https://repo.maven.apache.org/maven2/ch/qos/logback/logback-classic/1.0.12/logback-classic-1.0.12.jar"
+ dest="${maven.repo.local}/ch/qos/logback/logback-classic/1.0.12/logback-classic-1.0.12.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/ch/qos/logback/logback-core/1.0.12"/>
+ <get src="http://repository.apache.org/snapshots/ch/qos/logback/logback-core/1.0.12/logback-core-1.0.12.jar"
+ dest="${maven.repo.local}/ch/qos/logback/logback-core/1.0.12/logback-core-1.0.12.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="https://repo.maven.apache.org/maven2/ch/qos/logback/logback-core/1.0.12/logback-core-1.0.12.jar"
+ dest="${maven.repo.local}/ch/qos/logback/logback-core/1.0.12/logback-core-1.0.12.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/jackrabbit-webdav/jackrabbit-webdav-2.10.1.ebuild b/dev-java/jackrabbit-webdav/jackrabbit-webdav-2.10.1.ebuild
new file mode 100644
index 000000000000..a511edf66938
--- /dev/null
+++ b/dev-java/jackrabbit-webdav/jackrabbit-webdav-2.10.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="${PN/-*/}"
+
+DESCRIPTION="Fully conforming implementation of the JRC API (specified in JSR 170 and 283)"
+HOMEPAGE="http://jackrabbit.apache.org/"
+SRC_URI="mirror://apache/${MY_PN}/${PV}/${MY_PN}-${PV}-src.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+S="${WORKDIR}/${MY_PN}-${PV}/${PN}"
+
+CDEPEND="dev-java/bndlib:0
+ dev-java/slf4j-api:0
+ dev-java/slf4j-nop:0
+ dev-java/commons-httpclient:3
+ java-virtuals/servlet-api:2.3"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}
+ test? ( dev-java/ant-junit:0 )"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="
+ bndlib
+ commons-httpclient-3
+ servlet-api-2.3
+ slf4j-api
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-OutputContextImplTest.java.patch
+ "${FILESDIR}"/${P}-CSRFUtilTest.java.patch
+)
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+ epatch ${PATCHES[@]}
+}
+
+EANT_TEST_GENTOO_CLASSPATH="
+ ${EANT_GENTOO_CLASSPATH}
+ slf4j-nop
+"
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+}
diff --git a/dev-java/jackrabbit-webdav/metadata.xml b/dev-java/jackrabbit-webdav/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/jackrabbit-webdav/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>