summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-02-20 00:36:35 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-02-20 01:12:12 +0000
commit9501622c9a48ea74cd6d68fba788e5688838059a (patch)
treefdcaa1a6feaf9e895cfd4cffe700f9438f8b91d5 /dev-java/hoteqn
parentdev-java/jempbox: Clean up old. (diff)
downloadgentoo-9501622c9a48ea74cd6d68fba788e5688838059a.tar.gz
gentoo-9501622c9a48ea74cd6d68fba788e5688838059a.tar.bz2
gentoo-9501622c9a48ea74cd6d68fba788e5688838059a.zip
dev-java/hoteqn: EAPI 5 bump. Switch to java-pkg-simple.
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/hoteqn')
-rw-r--r--dev-java/hoteqn/hoteqn-4.0.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/hoteqn/hoteqn-4.0.0-r1.ebuild b/dev-java/hoteqn/hoteqn-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..7d69aae44988
--- /dev/null
+++ b/dev-java/hoteqn/hoteqn-4.0.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java applet to view and display LaTeX mathematical equations"
+HOMEPAGE="http://www.atp.ruhr-uni-bochum.de/VCLab/software/HotEqn/HotEqn.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT=0
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ app-arch/unzip
+ >=virtual/jdk-1.6"
+
+JAVA_ENCODING="ISO-8859-1"
+
+S="${WORKDIR}/${P}"
+
+java_prepare() {
+ rm -v mHotEqn.java || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ java-pkg_addres "${PN}.jar" classes/ -name "*.gif"
+}