summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/hoteqn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/hoteqn')
-rw-r--r--dev-java/hoteqn/Manifest1
-rw-r--r--dev-java/hoteqn/hoteqn-4.0.0.ebuild33
-rw-r--r--dev-java/hoteqn/metadata.xml5
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-java/hoteqn/Manifest b/dev-java/hoteqn/Manifest
new file mode 100644
index 000000000000..56ec1a0bacb6
--- /dev/null
+++ b/dev-java/hoteqn/Manifest
@@ -0,0 +1 @@
+DIST hoteqn-4.0.0.tar.bz2 98714 SHA256 a38d29c2d774a8c4b508635dfef4b17f34c48ca972ef13185dd318ff7d5051d8 SHA512 a0277340bec5ca0c5535d79e091218b88eb7d3c809859fc234de59b65d3b8b6c00fac667e00f3a2f6d0b3613f8a079bdfe7ea7e40a1bf484797a09a59de0323d WHIRLPOOL 617c2e4ded198e10981fb366fca8b2b9ad97aeb1a971651f48a247db80c90190faaf9d4b55fa750525a2190891cd2fc7c1d91fae292bd11c0b3e994ff71ea01e
diff --git a/dev-java/hoteqn/hoteqn-4.0.0.ebuild b/dev-java/hoteqn/hoteqn-4.0.0.ebuild
new file mode 100644
index 000000000000..d0385f5d6eed
--- /dev/null
+++ b/dev-java/hoteqn/hoteqn-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2
+
+DESCRIPTION="Java applet to view and display LaTeX mathematical equations"
+HOMEPAGE="http://www.atp.ruhr-uni-bochum.de/VCLab/software/HotEqn/HotEqn.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT=0
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4"
+
+src_unpack() {
+ unpack "${A}"
+ rm -v "${S}"/mHotEqn.java || die
+}
+
+src_compile() {
+ ejavac -nowarn -d classes $(find . -name "*.java") || die "failed to build"
+ jar cf ${PN}.jar -C classes . || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+}
+
+pkg_postinst() {
+ elog "We don't currently build the browser applet part. File a bug if you need it."
+}
diff --git a/dev-java/hoteqn/metadata.xml b/dev-java/hoteqn/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/hoteqn/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>