summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/regex-posix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/regex-posix')
-rw-r--r--dev-haskell/regex-posix/Manifest2
-rw-r--r--dev-haskell/regex-posix/files/regex-posix-0.95.1-control-exception.patch56
-rw-r--r--dev-haskell/regex-posix/files/regex-posix-0.95.1-ghc-7.5.patch12
-rw-r--r--dev-haskell/regex-posix/metadata.xml8
-rw-r--r--dev-haskell/regex-posix/regex-posix-0.95.1.ebuild25
-rw-r--r--dev-haskell/regex-posix/regex-posix-0.95.2.ebuild24
6 files changed, 127 insertions, 0 deletions
diff --git a/dev-haskell/regex-posix/Manifest b/dev-haskell/regex-posix/Manifest
new file mode 100644
index 000000000000..4bc0f03dce09
--- /dev/null
+++ b/dev-haskell/regex-posix/Manifest
@@ -0,0 +1,2 @@
+DIST regex-posix-0.95.1.tar.gz 42808 SHA256 74ed145b1a5b3c766a2694a58661f1d5e03a8dee283c5ddb9d689cff16efef0a SHA512 8d5758c286cda9fe0e18ee58d36b4481722bf2c6f59b8d29767817ddff80f527b3ae2c3b1cd0db6074bde019c56129d1baef5f97828bbc8e9f46bb70890a57fb WHIRLPOOL 300a65a9fc5093ed6643232ce2d03d25ab7714367fdc911a53ff8b8ed1fa1f12fcb2ee7f75701f1e80362cef61be5b09e3d838c2ab8a8d9115c59bf68fcb3025
+DIST regex-posix-0.95.2.tar.gz 42916 SHA256 56019921cd4a4c9682b81ec614236fea816ba8ed8785a1640cd66d8b24fc703e SHA512 2d22951f0302de144483d2c11d0711dc2cbd2fc6a0eac0126011eaa6f577837ae8c2a9516badb4beed6c18311241458dd6ad9f82a11d6f3763891880ebbc8c41 WHIRLPOOL 8d805d9a30caaf61c3498b8ec3ade8edcd5c5dd487878748d4fdb9f5ef03e73235df12749efbd88c179feaa5ba52400396ba1c98f569f3fed8eeae05f6ab1cd9
diff --git a/dev-haskell/regex-posix/files/regex-posix-0.95.1-control-exception.patch b/dev-haskell/regex-posix/files/regex-posix-0.95.1-control-exception.patch
new file mode 100644
index 000000000000..dfdfa71522f5
--- /dev/null
+++ b/dev-haskell/regex-posix/files/regex-posix-0.95.1-control-exception.patch
@@ -0,0 +1,56 @@
+diff --git a/Text/Regex/Posix/Wrap.hsc b/Text/Regex/Posix/Wrap.hsc
+index d27b756..a43bcc3 100644
+--- a/Text/Regex/Posix/Wrap.hsc
++++ b/Text/Regex/Posix/Wrap.hsc
+@@ -102,7 +102,7 @@ module Text.Regex.Posix.Wrap(
+ -- string.h is needed for memset
+
+ #include "myfree.h"
+-
++
+ #include "string.h"
+
+ #ifndef _POSIX_C_SOURCE
+@@ -131,10 +131,19 @@ import Foreign(Ptr, FunPtr, nullPtr, newForeignPtr,
+ addForeignPtrFinalizer, Storable(peekByteOff), allocaArray,
+ allocaBytes, withForeignPtr,ForeignPtr,plusPtr,peekElemOff)
+ import Foreign.Marshal.Alloc(mallocBytes)
+-import Foreign.C(CSize,CInt,CChar)
++import Foreign.C(CChar)
++#if __GLASGOW_HASKELL__ >= 703
++import Foreign.C(CSize(CSize),CInt(CInt))
++#else
++import Foreign.C(CSize,CInt)
++#endif
+ import Foreign.C.String(peekCAString, CString)
+ import Text.Regex.Base.RegexLike(RegexOptions(..),RegexMaker(..),RegexContext(..),MatchArray)
+-import qualified System.IO.Error as IOERROR(try)
++-- deprecated: import qualified System.IO.Error as IOERROR(try)
++import qualified Control.Exception(try,IOException)
++
++try :: IO a -> IO (Either Control.Exception.IOException a)
++try = Control.Exception.try
+
+ type CRegex = () -- dummy regex_t used below to read out nsub value
+
+@@ -349,8 +358,10 @@ foreign import ccall unsafe "&myregfree"
+ foreign import ccall unsafe "regcomp"
+ c_regcomp :: Ptr CRegex -> CString -> CompOption -> IO ReturnCode
+
++{- NOT USED
+ foreign import ccall unsafe "&regfree"
+ c_regfree :: FunPtr (Ptr CRegex -> IO ())
++-}
+
+ foreign import ccall unsafe "regexec"
+ c_regexec :: Ptr CRegex -> CString -> CSize
+@@ -460,7 +471,7 @@ wrapError errCode regex_ptr = do
+ ----------
+ wrapCompile flags e pattern = do
+ nullTest pattern "wrapCompile pattern" $ do
+- e_regex_ptr <- IOERROR.try $ mallocBytes (#const sizeof(regex_t)) -- ioError called if nullPtr
++ e_regex_ptr <- try $ mallocBytes (#const sizeof(regex_t)) -- ioError called if nullPtr
+ case e_regex_ptr of
+ Left ioerror -> return (Left (retOk,"Text.Regex.Posix.Wrap.wrapCompile: IOError from mallocBytes(regex_t) : "++show ioerror))
+ Right raw_regex_ptr -> do
+
diff --git a/dev-haskell/regex-posix/files/regex-posix-0.95.1-ghc-7.5.patch b/dev-haskell/regex-posix/files/regex-posix-0.95.1-ghc-7.5.patch
new file mode 100644
index 000000000000..e0de5a751637
--- /dev/null
+++ b/dev-haskell/regex-posix/files/regex-posix-0.95.1-ghc-7.5.patch
@@ -0,0 +1,12 @@
+--- regex-posix-0.95.1-orig/Text/Regex/Posix/Wrap.hsc 2011-05-10 01:55:41.000000000 +1000
++++ regex-posix-0.95.1/Text/Regex/Posix/Wrap.hsc 2012-05-13 18:06:06.314466286 +1000
+@@ -133,6 +133,9 @@
+ import Foreign.Marshal.Alloc(mallocBytes)
+ import Foreign.C(CSize,CInt,CChar)
+ import Foreign.C.String(peekCAString, CString)
++#if (__GLASGOW_HASKELL__>=705)
++import Foreign.C.Types(CInt(..), CSize(..))
++#endif
+ import Text.Regex.Base.RegexLike(RegexOptions(..),RegexMaker(..),RegexContext(..),MatchArray)
+ import qualified System.IO.Error as IOERROR(try)
+
diff --git a/dev-haskell/regex-posix/metadata.xml b/dev-haskell/regex-posix/metadata.xml
new file mode 100644
index 000000000000..648a58df5e2a
--- /dev/null
+++ b/dev-haskell/regex-posix/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ The posix regex backend for regex-base
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/regex-posix/regex-posix-0.95.1.ebuild b/dev-haskell/regex-posix/regex-posix-0.95.1.ebuild
new file mode 100644
index 000000000000..197cce55f6db
--- /dev/null
+++ b/dev-haskell/regex-posix/regex-posix-0.95.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit base haskell-cabal
+
+DESCRIPTION="Replaces/Enhances Text.Regex"
+HOMEPAGE="http://sourceforge.net/projects/lazy-regex"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-haskell/regex-base-0.93[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+PATCHES=("${FILESDIR}/${PN}-0.95.1-control-exception.patch"
+ "${FILESDIR}/${PN}-0.95.1-ghc-7.5.patch")
diff --git a/dev-haskell/regex-posix/regex-posix-0.95.2.ebuild b/dev-haskell/regex-posix/regex-posix-0.95.2.ebuild
new file mode 100644
index 000000000000..96a6db18fc76
--- /dev/null
+++ b/dev-haskell/regex-posix/regex-posix-0.95.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit base haskell-cabal
+
+DESCRIPTION="Replaces/Enhances Text.Regex"
+HOMEPAGE="http://sourceforge.net/projects/lazy-regex"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-haskell/regex-base-0.93[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+PATCHES=("${FILESDIR}/${PN}-0.95.1-ghc-7.5.patch")