summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/hdbc-postgresql
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/hdbc-postgresql')
-rw-r--r--dev-haskell/hdbc-postgresql/Manifest3
-rw-r--r--dev-haskell/hdbc-postgresql/files/HDBC-postgresql-2.3.2.1-ghc-7.6.patch53
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild65
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2-r2.ebuild62
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.3.ebuild64
-rw-r--r--dev-haskell/hdbc-postgresql/metadata.xml11
6 files changed, 258 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-postgresql/Manifest b/dev-haskell/hdbc-postgresql/Manifest
new file mode 100644
index 000000000000..1be575ff6bf9
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/Manifest
@@ -0,0 +1,3 @@
+DIST HDBC-postgresql-2.3.2.1.tar.gz 24683 SHA256 ebda9d5809d9e24ad67234784df9d75af1b12c6a32d87b221bb785d4080721ca SHA512 12576203936d7c939688946160133174b12082c6684554f6f5a8e3c44251982c13eacdf9a18a45c21e877a220178b303299a3b3e72cb828cf58dede2b9c519cb WHIRLPOOL 08491a2f4ad67fce8ee14fa935499af91bbb0927241bdd51dc0d91acd1543b7ff200abb6d8d05fca43d9df304d4b0ad0450414079eccaec381679c1cbf394552
+DIST HDBC-postgresql-2.3.2.2.tar.gz 24872 SHA256 20351800e414133200b92a00fc81d0bd475ae3f2ae5829c49fb2b72488a38274 SHA512 a3ae0a1482b45c4ea5a227b8074fbedf5f02b9d5ae479b086293514fbc375c8078d86bf591c965a0772e26e0a129ee5c21ccfbe33a232d68f7440c6a7cf4124c WHIRLPOOL b1f6ea9dc24913d7204065f39018816ff5a9774330820b43eab67e20efedfde6d6b94c84a70cab386b32028d61f6e7673fde180d747de38196a633aa8a2b760d
+DIST HDBC-postgresql-2.3.2.3.tar.gz 25193 SHA256 4396038e1a66ba14b6b3388f2ee303c938e55c3fe0fe5df059a70335761e64cb SHA512 407b18758e75e99230dbad56000839d8499c075e77b63809e079c7968e52177cc599dff30517f8cd08c3e4e263a71a4c65b3040c318b4b3358ff329824f4766f WHIRLPOOL 109fc346b9e3eedbe6a4ab9d24619207aaf25e4ce54aee03fb77c6a6d4dea2ff9bbac0f1ae304c9f6c87526c3617f0d335482c80f52530e592727e0c445b2ba8
diff --git a/dev-haskell/hdbc-postgresql/files/HDBC-postgresql-2.3.2.1-ghc-7.6.patch b/dev-haskell/hdbc-postgresql/files/HDBC-postgresql-2.3.2.1-ghc-7.6.patch
new file mode 100644
index 000000000000..2f81f35c1410
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/files/HDBC-postgresql-2.3.2.1-ghc-7.6.patch
@@ -0,0 +1,53 @@
+--- HDBC-postgresql-2.3.2.1-orig/testsrc/TestSbasics.hs 2012-03-04 04:08:01.000000000 +1100
++++ HDBC-postgresql-2.3.2.1/testsrc/TestSbasics.hs 2012-10-13 11:08:27.482597846 +1100
+@@ -1,10 +1,14 @@
++{-# LANGUAGE CPP, ScopedTypeVariables #-}
+ module TestSbasics(tests) where
+ import Test.HUnit
+ import Data.List
+ import Database.HDBC
+ import TestUtils
+ import System.IO
+-import Control.Exception hiding (catch)
++#if !MIN_VERSION_base(4,6,0)
++import Prelude hiding (catch)
++#endif
++import Control.Exception
+
+ openClosedb = sqlTestCase $
+ do dbh <- connectDB
+@@ -142,7 +146,7 @@
+ -- Let's try a rollback.
+ catch (withTransaction dbh (\_ -> do sExecuteMany sth rows
+ fail "Foo"))
+- (\_ -> return ())
++ (\(_::IOException) -> return ())
+ sExecute qrysth []
+ sFetchAllRows qrysth >>= (assertEqual "rollback" [[Just "0"]])
+
+--- HDBC-postgresql-2.3.2.1-orig/testsrc/Testbasics.hs 2012-03-04 04:08:01.000000000 +1100
++++ HDBC-postgresql-2.3.2.1/testsrc/Testbasics.hs 2012-10-13 11:07:43.622396904 +1100
+@@ -1,9 +1,13 @@
++{-# LANGUAGE CPP, ScopedTypeVariables #-}
+ module Testbasics(tests) where
+ import Test.HUnit
+ import Database.HDBC
+ import TestUtils
+ import System.IO
+-import Control.Exception hiding (catch)
++#if !MIN_VERSION_base(4,6,0)
++import Prelude hiding (catch)
++#endif
++import Control.Exception
+
+ openClosedb = sqlTestCase $
+ do dbh <- connectDB
+@@ -140,7 +144,7 @@
+ -- Let's try a rollback.
+ catch (withTransaction dbh (\_ -> do executeMany sth rows
+ fail "Foo"))
+- (\_ -> return ())
++ (\(_::IOException) -> return ())
+ execute qrysth []
+ fetchAllRows qrysth >>= (assertEqual "rollback" [[SqlString "0"]])
+
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild
new file mode 100644
index 000000000000..e79ab7c6c8e8
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit base haskell-cabal versionator
+
+MY_PN="HDBC-postgresql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL driver for HDBC"
+HOMEPAGE="http://github.com/hdbc/hdbc-postgresql"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # requires configured postgresql
+
+hdbc_PV=$(get_version_component_range 1-2)
+
+RDEPEND=">dev-db/postgresql-8
+ dev-haskell/convertible[profile?]
+ =dev-haskell/hdbc-${hdbc_PV}*[profile?]
+ dev-haskell/mtl[profile?]
+ dev-haskell/parsec[profile?]
+ dev-haskell/utf8-string[profile?]
+ >=dev-lang/ghc-6.8.2
+ >=dev-db/postgresql-8"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/convertible
+ dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/testpack
+ )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=("${FILESDIR}/${MY_PN}-2.3.2.1-ghc-7.6.patch")
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2-r2.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2-r2.ebuild
new file mode 100644
index 000000000000..e1c52f78dd86
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+CABAL_FEATURES+=" nocabaldep" # workaround depend on old cabal-1.16
+inherit haskell-cabal
+
+MY_PN="HDBC-postgresql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL driver for HDBC"
+HOMEPAGE="http://github.com/hdbc/hdbc-postgresql"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # requires configured postgresql
+
+RDEPEND=">=dev-db/postgresql-7:*
+ dev-haskell/convertible:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ >=dev-haskell/hdbc-2.2.0:2=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( >=dev-haskell/hdbc-2.2.6:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/quickcheck:2=[profile?]
+ dev-haskell/testpack:=[profile?] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.3.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.3.ebuild
new file mode 100644
index 000000000000..79f29e942c43
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+CABAL_FEATURES+=" nocabaldep" # workaround depend on old cabal-1.16
+inherit haskell-cabal
+
+MY_PN="HDBC-postgresql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL driver for HDBC"
+HOMEPAGE="http://github.com/hdbc/hdbc-postgresql"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # requires configured postgresql
+
+RDEPEND=">=dev-db/postgresql-7:*
+ dev-haskell/convertible:=[profile?]
+ >=dev-haskell/hdbc-2.2.0:2=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( >=dev-haskell/hdbc-2.2.6:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/quickcheck:2=[profile?]
+ dev-haskell/testpack:=[profile?] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}
diff --git a/dev-haskell/hdbc-postgresql/metadata.xml b/dev-haskell/hdbc-postgresql/metadata.xml
new file mode 100644
index 000000000000..e171b0d92ee7
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hdbc/hdbc-postgresql</remote-id>
+ </upstream>
+</pkgmetadata>