summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2022-03-12 20:54:18 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2022-03-12 20:54:32 +0300
commitcd737a0f0bcf377b3b36294b05343541ad60d6eb (patch)
tree1dbdd11a8173f7ede8c53a54bd4d4f588226599c /dev-db
parentdev-libs/mimalloc: update DESCRIPTION (diff)
downloadgentoo-cd737a0f0bcf377b3b36294b05343541ad60d6eb.tar.gz
gentoo-cd737a0f0bcf377b3b36294b05343541ad60d6eb.tar.bz2
gentoo-cd737a0f0bcf377b3b36294b05343541ad60d6eb.zip
dev-db/pglogical: Initial import
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pglogical/Manifest1
-rw-r--r--dev-db/pglogical/metadata.xml11
-rw-r--r--dev-db/pglogical/pglogical-2.4.1.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-db/pglogical/Manifest b/dev-db/pglogical/Manifest
new file mode 100644
index 000000000000..e276cb38f5fe
--- /dev/null
+++ b/dev-db/pglogical/Manifest
@@ -0,0 +1 @@
+DIST REL2_4_1.tar.gz 277428 BLAKE2B 51319e3b1491e1857e63e63640f2e6d2315ab72a0aabcfe7869456822a294bdb53fd0f4cc9bca0c60bfcf9e0926249acad86f09327c5656735b508851037ccaf SHA512 0d673e1a2b696e2cfbb94d8350bb15c280947f69b6512aa80f8ef7497e30cbd407a01b9a4f8fa9844b4ccb39377a6b2bee390a7887f3050074c2e6a11e6f3e3f
diff --git a/dev-db/pglogical/metadata.xml b/dev-db/pglogical/metadata.xml
new file mode 100644
index 000000000000..f94345495aef
--- /dev/null
+++ b/dev-db/pglogical/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">2ndQuadrant/pglogical</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/pglogical/pglogical-2.4.1.ebuild b/dev-db/pglogical/pglogical-2.4.1.ebuild
new file mode 100644
index 000000000000..d886bbb793cf
--- /dev/null
+++ b/dev-db/pglogical/pglogical-2.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+POSTGRES_COMPAT=( 9.6 {10..14} )
+
+inherit postgres-multi
+
+MY_PV=$(ver_rs 1- '_')
+MY_P="${PN}-${MY_PV}"
+S="${WORKDIR}/${PN}-REL${MY_PV}"
+
+DESCRIPTION="Logical replication for PostgreSQL"
+HOMEPAGE="https://www.2ndquadrant.com/en/resources/pglogical/"
+SRC_URI="https://github.com/2ndQuadrant/pglogical/archive/REL${MY_PV}.tar.gz"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ postgres-multi_foreach emake USE_PGXS=1 || die "emake failed"
+}
+
+src_install() {
+ postgres-multi_foreach emake DESTDIR="${D}" USE_PGXS=1 install
+ postgres-multi_foreach dobin pglogical_create_subscriber
+}