summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-27 19:39:38 +0000
committerSam James <sam@gentoo.org>2022-03-07 03:23:47 +0000
commit5d106a66c955d3e8b9119f1deea5e5a0993a3985 (patch)
tree7b442a5db14bc507640d6ca8c0bd73625537c70b /dev-cpp/folly
parentdev-libs/libfmt: add static assert patch (diff)
downloadgentoo-5d106a66c955d3e8b9119f1deea5e5a0993a3985.tar.gz
gentoo-5d106a66c955d3e8b9119f1deea5e5a0993a3985.tar.bz2
gentoo-5d106a66c955d3e8b9119f1deea5e5a0993a3985.zip
dev-cpp/folly: initial import (2022.02.28.00)
Needed for dev-util/watchman. Closes: https://bugs.gentoo.org/787719 Closes: https://bugs.gentoo.org/419599 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/folly')
-rw-r--r--dev-cpp/folly/Manifest1
-rw-r--r--dev-cpp/folly/folly-2022.02.28.00.ebuild60
-rw-r--r--dev-cpp/folly/metadata.xml11
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-cpp/folly/Manifest b/dev-cpp/folly/Manifest
new file mode 100644
index 000000000000..22ba1e56a8d7
--- /dev/null
+++ b/dev-cpp/folly/Manifest
@@ -0,0 +1 @@
+DIST folly-2022.02.28.00.tar.gz 3600258 BLAKE2B 5943b0e4b6178c8293714f673ed289daed26b1dad22dcb52dc80475f385961cf0a690accc44139f245f2df5cf10c0bdb5638c8bed52cb97fefd3ad6d8dc147b8 SHA512 91ee21e463ffc6eee3b0e5e0244721a9612337b9afe92645556a154f521aec1070f4f381962247bb9bf11592efb5b8bb01f70d1a66acd3444967538062dfe826
diff --git a/dev-cpp/folly/folly-2022.02.28.00.ebuild b/dev-cpp/folly/folly-2022.02.28.00.ebuild
new file mode 100644
index 000000000000..d9c4c5003e07
--- /dev/null
+++ b/dev-cpp/folly/folly-2022.02.28.00.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="An open-source C++ library developed and used at Facebook"
+HOMEPAGE="https://github.com/facebook/folly"
+SRC_URI="https://github.com/facebook/folly/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="llvm-libunwind test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-arch/bzip2
+ app-arch/lz4:=
+ app-arch/snappy:=
+ app-arch/xz-utils
+ app-arch/zstd:=
+ dev-cpp/gflags:=
+ dev-cpp/glog[gflags]
+ dev-libs/boost:=[context,threads(+)]
+ dev-libs/double-conversion:=
+ dev-libs/libaio
+ dev-libs/libevent:=
+ dev-libs/libfmt:=
+ dev-libs/libsodium:=
+ dev-libs/openssl:=
+ sys-libs/liburing:=
+ sys-libs/zlib
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ !llvm-libunwind? ( sys-libs/libunwind:= )"
+# libiberty is linked statically
+DEPEND="${RDEPEND}
+ sys-libs/binutils-libs"
+
+pkg_setup() {
+ if use test && [[ ${BUILD_TYPE} != "binary" ]] && ! tc-is-clang ; then
+ ewarn "Forcing build with Clang due to GCC bug (because tests are enabled)"
+ ewarn "(https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104008)"
+
+ export CC=${CHOST}-clang
+ export CXX=${CHOST}-clang++
+ fi
+}
+
+src_configure() {
+ # TODO: liburing could in theory be optional but fails to link
+
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+
+ -DBUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/folly/metadata.xml b/dev-cpp/folly/metadata.xml
new file mode 100644
index 000000000000..a512b80f6fcb
--- /dev/null
+++ b/dev-cpp/folly/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">facebook/folly</remote-id>
+ </upstream>
+</pkgmetadata>