summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2024-09-07 17:21:10 +0100
committerPetr Vaněk <arkamar@gentoo.org>2024-09-07 20:40:11 +0200
commitc8842aa7b565b4078c0611a34746e4c0c3ab8806 (patch)
tree8da3636e589a7a6d088dac6b42c922533691dc19 /app-text
parentsys-firmware/intel-microcode: drop 20240312_p20240312 (diff)
downloadgentoo-c8842aa7b565b4078c0611a34746e4c0c3ab8806.tar.gz
gentoo-c8842aa7b565b4078c0611a34746e4c0c3ab8806.tar.bz2
gentoo-c8842aa7b565b4078c0611a34746e4c0c3ab8806.zip
app-text/pdfminer: add 20240706
Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38500 Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pdfminer/Manifest1
-rw-r--r--app-text/pdfminer/pdfminer-20240706.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-text/pdfminer/Manifest b/app-text/pdfminer/Manifest
index bc4be7f0c4ab..b5ae66a2b053 100644
--- a/app-text/pdfminer/Manifest
+++ b/app-text/pdfminer/Manifest
@@ -1,2 +1,3 @@
DIST pdfminer-20220506.tar.gz 10853104 BLAKE2B b6008db789973fb69537801b8e928761bd0a949cc72ddf380fd71b6373913f6a689b71bee159e6991e99c196b7e8a1fac5530d2bf9c577e53b8b556bed00b85a SHA512 b81916c70f22f3408cf41a50d35937f950ee6205f59fa03603bc7a78d1b1b037311ebaf5661f6d46b9d4190f2f56189fc28b714463dc5854328c14f97fbc28c4
DIST pdfminer.six-20221105.gh.tar.gz 10857730 BLAKE2B dd9282bfc3c636676f087e6ffc2cfb137f66eee18427f08de488c7bdc13bd27b6cc674d3b75c93d1566668272ee4111e3347664a70152bd4b2f7e4e63664d01b SHA512 72034a75005c91100274f86baa4c8884caad86aacf94ca9d0d5a51d8b3c772aa0bcd766416bed9e26df00bd9a2be585649eaa24321735f532e40a3871e19c6df
+DIST pdfminer.six-20240706.gh.tar.gz 11010877 BLAKE2B 7253d9fbdd44bce80b46d2006caa530b628327c2a2c5d68dd165267b7f2c1078895361da62b508991e4c0938163835a3381356e7353efd7208ee7b9e5ee3a0bd SHA512 01359926e889788daf92db8845978c3cd6e0b88c0659041d2df26d48e558a2918aa373ab86db19bc3c314220ed8c5070778d5b7fd1457b9145fe67aa735a94b5
diff --git a/app-text/pdfminer/pdfminer-20240706.ebuild b/app-text/pdfminer/pdfminer-20240706.ebuild
new file mode 100644
index 000000000000..5ce145c1bb21
--- /dev/null
+++ b/app-text/pdfminer/pdfminer-20240706.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+MY_P="${PN}.six-${PV}"
+DESCRIPTION="Python tool for extracting information from PDF documents"
+HOMEPAGE="https://pdfminersix.readthedocs.io/en/latest/"
+# Release tarballs lack tests
+SRC_URI="https://github.com/pdfminer/pdfminer.six/archive/refs/tags/${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=dev-python/charset-normalizer-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-36.0.0[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs/source "dev-python/sphinx-argparse"
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -z -e "s:setuptools_git_versioning={[^}]*}:version=${PV}:" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use examples && dodoc -r samples
+ distutils-r1_python_install_all
+}