summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-08-01 18:06:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-15 21:53:29 +0200
commitf957dd20b2016704813be78a6f8c44f3de003f9c (patch)
tree3b28ab07f3493f9b9094e31715d1dabd5111e7f7 /app-text/pep
parentapp-misc/cdspeed: EAPI7, improve ebuild (diff)
downloadgentoo-f957dd20b2016704813be78a6f8c44f3de003f9c.tar.gz
gentoo-f957dd20b2016704813be78a6f8c44f3de003f9c.tar.bz2
gentoo-f957dd20b2016704813be78a6f8c44f3de003f9c.zip
app-text/pep: EAPI7, improve ebuild
Diffstat (limited to 'app-text/pep')
-rw-r--r--app-text/pep/pep-2.8-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-text/pep/pep-2.8-r2.ebuild b/app-text/pep/pep-2.8-r2.ebuild
new file mode 100644
index 000000000000..8e25853adc30
--- /dev/null
+++ b/app-text/pep/pep-2.8-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="General purpose filter and file cleaning program"
+HOMEPAGE="http://hannemyr.com/enjoy/pep.html"
+SRC_URI="http://hannemyr.com/enjoy/${PN}${PV//./}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86 ~x86-linux ~ppc-macos"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+# pep does not come with autconf so here's a patch to configure
+# Makefile with the correct path
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-include.patch
+)
+
+src_prepare() {
+ default
+ # Darwin lacks stricmp and DIRCHAR
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i -e '/^OBJS/s/^\(.*\)$/\1 bdmg.o/' Makefile || die
+ append-flags "-Dunix" -DSTRICMP
+ fi
+}
+
+src_compile() {
+ # make man page too
+ make Doc/pep.1 || die "make man page failed"
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin pep
+ doman Doc/pep.1
+
+ insinto /usr/share/pep
+ doins Filters/*
+
+ dodoc aareadme.txt file_id.diz
+}