summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-25 17:32:07 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-25 20:15:34 +0100
commitd4c26979beb5eb3b50ce32bbf623fb4da457186a (patch)
tree7f9fbc2639700d93639e7d9d95ccb5602170f2f1 /app-text/nfoview
parentapp-editors/vim: stable 8.0.1298 for ppc64, bug #639710 (diff)
downloadgentoo-d4c26979beb5eb3b50ce32bbf623fb4da457186a.tar.gz
gentoo-d4c26979beb5eb3b50ce32bbf623fb4da457186a.tar.bz2
gentoo-d4c26979beb5eb3b50ce32bbf623fb4da457186a.zip
app-text/nfoview: [QA] Port to git-r3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-text/nfoview')
-rw-r--r--app-text/nfoview/nfoview-1.15.1.ebuild20
-rw-r--r--app-text/nfoview/nfoview-9999.ebuild20
2 files changed, 18 insertions, 22 deletions
diff --git a/app-text/nfoview/nfoview-1.15.1.ebuild b/app-text/nfoview/nfoview-1.15.1.ebuild
index e96a9fe27f54..eacdccc7a4a3 100644
--- a/app-text/nfoview/nfoview-1.15.1.ebuild
+++ b/app-text/nfoview/nfoview-1.15.1.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )
-inherit distutils-r1 fdo-mime gnome2-utils
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/otsaloma/nfoview.git
- https://github.com/otsaloma/nfoview.git"
- inherit git-2
- SRC_URI=""
- #KEYWORDS=""
+inherit distutils-r1 gnome2-utils xdg-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
+ inherit git-r3
else
SRC_URI="http://download.gna.org/nfoview/${PV:0:4}/${P}.tar.xz"
KEYWORDS="amd64 x86"
@@ -24,7 +22,7 @@ LICENSE="GPL-3"
SLOT="0"
IUSE=""
-DEPEND="dev-python/pygobject:3"
+DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
media-fonts/terminus-font"
@@ -34,10 +32,10 @@ pkg_preinst() {
pkg_postinst() {
gnome2_icon_cache_update
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
}
pkg_postrm() {
gnome2_icon_cache_update
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-text/nfoview/nfoview-9999.ebuild b/app-text/nfoview/nfoview-9999.ebuild
index 58b524bbcffb..f8030006af37 100644
--- a/app-text/nfoview/nfoview-9999.ebuild
+++ b/app-text/nfoview/nfoview-9999.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )
-inherit distutils-r1 fdo-mime gnome2-utils
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/otsaloma/nfoview.git
- https://github.com/otsaloma/nfoview.git"
- inherit git-2
- SRC_URI=""
- #KEYWORDS=""
+inherit distutils-r1 gnome2-utils xdg-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
+ inherit git-r3
else
SRC_URI="http://download.gna.org/nfoview/${PV:0:4}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
@@ -24,7 +22,7 @@ LICENSE="GPL-3"
SLOT="0"
IUSE=""
-DEPEND="dev-python/pygobject:3"
+DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
media-fonts/terminus-font"
@@ -34,10 +32,10 @@ pkg_preinst() {
pkg_postinst() {
gnome2_icon_cache_update
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
}
pkg_postrm() {
gnome2_icon_cache_update
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
}