summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2024-06-06 08:51:58 -0400
committerRick Farina <zerochaos@gentoo.org>2024-06-06 08:52:42 -0400
commitf47fa22bdc6b6fe8e134cd72f26654038d1ad4dd (patch)
treead7927a7caeca4b55ed4923b961f0bc633a8f8d0 /app-misc
parentdev-util/nvidia-cuda-toolkit: delete gdb files only with USE=debugger (diff)
downloadgentoo-f47fa22bdc6b6fe8e134cd72f26654038d1ad4dd.tar.gz
gentoo-f47fa22bdc6b6fe8e134cd72f26654038d1ad4dd.tar.bz2
gentoo-f47fa22bdc6b6fe8e134cd72f26654038d1ad4dd.zip
app-misc/liquidctl: fix some test failures
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/liquidctl/files/709.patch32
-rw-r--r--app-misc/liquidctl/liquidctl-1.13.0.ebuild3
2 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/liquidctl/files/709.patch b/app-misc/liquidctl/files/709.patch
new file mode 100644
index 000000000000..dd0d6420a9da
--- /dev/null
+++ b/app-misc/liquidctl/files/709.patch
@@ -0,0 +1,32 @@
+From 470b159fddbf595ccbf6995b4f9e6a1462e97c65 Mon Sep 17 00:00:00 2001
+From: Jonas Malaco <jonas@protocubo.io>
+Date: Tue, 21 May 2024 15:53:40 -0300
+Subject: [PATCH] test_cli: don't change the type of sys.argv when
+ monkeypatching it
+
+When setting up for the CLI tests, we inadvertently change the type of
+sys.argv from list to tuple. That worked with OG docopt, but breaks
+docopt-ng. More importantly, the Python docs say sys.argv is a _list_.
+
+So even though docopt was able to handle it being a tuple, and docopt-ng
+seems (from a cursory look at its source) to still handle it being a
+string, let's use the correct type.
+
+Fixes: #708
+---
+ tests/test_cli.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_cli.py b/tests/test_cli.py
+index aa577ffc0..76791e896 100644
+--- a/tests/test_cli.py
++++ b/tests/test_cli.py
+@@ -11,7 +11,7 @@
+ def main(monkeypatch, capsys):
+ """Return a function f(*args) to run main with `args` as `sys.argv`."""
+ def call_with_args(*args):
+- monkeypatch.setattr(sys, 'argv', args)
++ monkeypatch.setattr(sys, 'argv', list(args))
+ try:
+ liquidctl.cli.main()
+ except SystemExit as exit:
diff --git a/app-misc/liquidctl/liquidctl-1.13.0.ebuild b/app-misc/liquidctl/liquidctl-1.13.0.ebuild
index a2eb2e0132a7..6cec41aae631 100644
--- a/app-misc/liquidctl/liquidctl-1.13.0.ebuild
+++ b/app-misc/liquidctl/liquidctl-1.13.0.ebuild
@@ -28,6 +28,9 @@ BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
"
+# This is a merged PR, remove it on bump
+PATCHES=( "${FILESDIR}/709.patch" )
+
distutils_enable_tests pytest
src_test() {