summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-10-27 18:42:02 -0400
committerMatt Turner <mattst88@gentoo.org>2023-10-27 18:59:38 -0400
commiteda53759a858cf5e48769e4728505a2e39375cbc (patch)
tree8f5ee443432a77506c9cc49b54ac19e803dae5c5 /app-misc
parentdev-python/cffi: Stabilize 1.16.0 sparc, #916347 (diff)
downloadgentoo-eda53759a858cf5e48769e4728505a2e39375cbc.tar.gz
gentoo-eda53759a858cf5e48769e4728505a2e39375cbc.tar.bz2
gentoo-eda53759a858cf5e48769e4728505a2e39375cbc.zip
app-misc/vit: Version bump to 2.3.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/vit/Manifest1
-rw-r--r--app-misc/vit/vit-2.3.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/vit/Manifest b/app-misc/vit/Manifest
index b00d38a0276c..3a1acc4b2a1f 100644
--- a/app-misc/vit/Manifest
+++ b/app-misc/vit/Manifest
@@ -1 +1,2 @@
DIST vit-2.3.1.tar.gz 72143 BLAKE2B 288e21083fc39d47aa1df6d3adf5b5973a50ab0463ad53a40ad70c1dbc627821ed4e567cd269749cca470fb7705f0f1792dca9db58cd16b504d5e0a0c2471097 SHA512 930c02ab2f399a0338a1a7f328a99452c1448bd9352c1f0535c720b6d4437ff29345a23a73af107aeac1091ad33829a563ce69daae53a44b684cf71a54d70d4b
+DIST vit-2.3.2.tar.gz 72321 BLAKE2B 45fb6725547f2a6703dd0862df522781f5a5fa7d7264a1c1dd95d28fcca688661c971abec789e93fa40b4c40b2c1991ca5b951b4d0439baeeb7ef7f82aed6e7a SHA512 f24a3bd238b390acb437b1a7bdd888f468196ddbf179d1aee9578ce1c83e6f973703d779c231c07024f81600066431661e312419ad5a4c81bcb1125a9f714f42
diff --git a/app-misc/vit/vit-2.3.2.ebuild b/app-misc/vit/vit-2.3.2.ebuild
new file mode 100644
index 000000000000..d55605c797ec
--- /dev/null
+++ b/app-misc/vit/vit-2.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=yes
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A lightweight, fast, curses-based front end to Taskwarrior"
+HOMEPAGE="
+ https://github.com/vit-project/vit
+ https://pypi.org/project/vit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-misc/task
+ $(python_gen_cond_dep '
+ >=dev-python/tasklib-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/urwid-2.1.2[${PYTHON_USEDEP}]
+ ')
+"
+
+distutils_enable_tests pytest