summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-12 12:15:08 -0500
committerTim Harder <radhermit@gentoo.org>2017-10-12 12:15:50 -0500
commitb40d9c83225d21852c841d3f17efde26c1cbc0d9 (patch)
tree8d3e0c1ca8d549e0a2869816a0a5f2242ae38c3a /app-misc/when
parentmedia-sound/abcmidi: version bump to 2017.10.11 (diff)
downloadgentoo-b40d9c83225d21852c841d3f17efde26c1cbc0d9.tar.gz
gentoo-b40d9c83225d21852c841d3f17efde26c1cbc0d9.tar.bz2
gentoo-b40d9c83225d21852c841d3f17efde26c1cbc0d9.zip
app-misc/when: version bump to 1.1.37
Diffstat (limited to 'app-misc/when')
-rw-r--r--app-misc/when/Manifest1
-rw-r--r--app-misc/when/when-1.1.37.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-misc/when/Manifest b/app-misc/when/Manifest
index 268ee044b60e..34242da444ee 100644
--- a/app-misc/when/Manifest
+++ b/app-misc/when/Manifest
@@ -1 +1,2 @@
DIST when-1.1.36.tar.gz 50926 SHA256 3ff95c1881e8fe25c82943720a81c9b9b3bd4ac002cd8ffc2d25c588fe7d50b1 SHA512 04b2efbcebae79325d8410a5aa5cdf59662fe42c06229ebc91f3b7163091d305a6ba91914a2a9117d86807d5ca0c875d48679dbc3545162a7263679bf605a52e WHIRLPOOL 1e7ed8d6e2939eaf898e01acebcd74f340e33eff5af17613e60eed62b756e8dd4df300990194b3cbebec64751c2adc1cb44848f1aad3d0b840bc9fe7174ea144
+DIST when-1.1.37.tar.gz 51020 SHA256 475e4b5070b383d2ad610e6610f8d2ff7995feab96e5d4de8d676063ad204733 SHA512 b1f0cb9cb797a5a32263ef2851498dfbf6a769d3e708b79ca1c5b37c7c877124194dd9b5ae78bfafebc0e73e82f306b3ae734a5ef7140fe3bf0e6b2cfcc4bb18 WHIRLPOOL 658a9307cca49f2ebc39ea06f2f61c5248280347dfa66f8c4ba158fa8f295fa956866310ad06be5e6c3d663a3ba1c3e3158586f56b972c52c1586215f636af1a
diff --git a/app-misc/when/when-1.1.37.ebuild b/app-misc/when/when-1.1.37.ebuild
new file mode 100644
index 000000000000..533d342eb72f
--- /dev/null
+++ b/app-misc/when/when-1.1.37.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Minimalistic personal calendar program"
+HOMEPAGE="http://www.lightandmatter.com/when/when.html"
+SRC_URI="http://www.lightandmatter.com/when/when.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/when_dist"
+
+DOCS=( README )
+
+src_prepare() {
+ default
+
+ # Fix path for tests
+ sed -i 's,^ when, ./when,' Makefile || die 'sed failed'
+}
+
+src_compile() { :; }
+
+src_test() {
+ # The when command requires these files, or attempts to run setup function.
+ mkdir "${HOME}"/.when || die 'mkdir failed'
+ touch "${HOME}"/.when/{calendar,preferences} || die 'touch failed'
+ emake test
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}