summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-10-10 10:19:48 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-10-10 10:19:48 +0200
commit33e005b13ab240174f3fdf991a22ceda1d0ed559 (patch)
treed2165b7a373802a4642bf7dd2812a303a9015bf2 /app-misc/vifm/vifm-0.13.ebuild
parentsys-libs/glibc: keyword 2.39-r11 (patchlevel 11) (diff)
downloadgentoo-33e005b13ab240174f3fdf991a22ceda1d0ed559.tar.gz
gentoo-33e005b13ab240174f3fdf991a22ceda1d0ed559.tar.bz2
gentoo-33e005b13ab240174f3fdf991a22ceda1d0ed559.zip
app-misc/vifm: drop 0.13
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-misc/vifm/vifm-0.13.ebuild')
-rw-r--r--app-misc/vifm/vifm-0.13.ebuild95
1 files changed, 0 insertions, 95 deletions
diff --git a/app-misc/vifm/vifm-0.13.ebuild b/app-misc/vifm/vifm-0.13.ebuild
deleted file mode 100644
index ae80765cc747..000000000000
--- a/app-misc/vifm/vifm-0.13.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools vim-doc xdg
-
-DESCRIPTION="Console file manager with vi(m)-like keybindings"
-HOMEPAGE="https://vifm.info/"
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/vifm/vifm"
- inherit git-r3
-else
- SRC_URI="https://github.com/vifm/vifm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 ppc x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+extended-keys gtk +magic +vim +vim-syntax X"
-
-DEPEND="
- >=sys-libs/ncurses-5.9-r3:=
- magic? ( sys-apps/file )
- gtk? ( x11-libs/gtk+:2 )
- X? ( x11-libs/libX11 )
-"
-RDEPEND="
- ${DEPEND}
- vim? ( || ( app-editors/vim app-editors/gvim ) )
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
-"
-# "Either perl or Vim is necessary to generate tags for documentation in Vim's format." from configure
-BDEPEND="|| ( dev-lang/perl app-editors/vim )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # developer just turns off optimisations and adds -Werror again
- # bug #855386
- econf \
- --disable-developer \
- --disable-werror \
- $(use_enable extended-keys) \
- $(use_with magic libmagic) \
- $(use_with gtk) \
- $(use_with X X11)
-}
-
-src_install() {
- default
-
- if use vim; then
- local t
- for t in app plugin; do
- insinto /usr/share/vim/vimfiles/"${t}"
- doins -r data/vim/doc/${t}/${PN}*
- done
- fi
-
- if use vim-syntax; then
- local t
- for t in ftdetect ftplugin syntax; do
- insinto /usr/share/vim/vimfiles/"${t}"
- doins -r data/vim/${t}/${PN}*
- done
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- if use vim; then
- update_vim_helptags
-
- if [[ -n ${REPLACING_VERSIONS} ]]; then
- elog
- elog "You don't need to copy or link any files for"
- elog " the vim plugin and documentation to work anymore."
- elog "If you copied any vifm files to ~/.vim/ manually"
- elog " in earlier vifm versions, please delete them."
- fi
- elog
- elog "To use vim in vifm to view the documentation"
- elog " edit ~/.vifm/vifmrc and set vimhelp instead of novimhelp"
- elog
- fi
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- use vim && update_vim_helptags
-}