summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/regex-markup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/regex-markup')
-rw-r--r--app-misc/regex-markup/Manifest1
-rw-r--r--app-misc/regex-markup/files/regex-markup-0.10.0-locale.patch29
-rw-r--r--app-misc/regex-markup/metadata.xml8
-rw-r--r--app-misc/regex-markup/regex-markup-0.10.0.ebuild34
4 files changed, 72 insertions, 0 deletions
diff --git a/app-misc/regex-markup/Manifest b/app-misc/regex-markup/Manifest
new file mode 100644
index 000000000000..c74ab978540d
--- /dev/null
+++ b/app-misc/regex-markup/Manifest
@@ -0,0 +1 @@
+DIST regex-markup-0.10.0.tar.gz 424480 SHA256 879f0af7622c1eb2d1b7c5f7d0ec53ea96fd48b05bc4f4c17542a2ea17fafba5 SHA512 fddb43b41771e5f75a140798304023087931da383cdee0b6fa9c0bd867e9e5280f484bc6182960c08993d91963de22fa9f0052e867a58067dfc39d9b761e0e9f WHIRLPOOL 2ec2c4c207437aafaab620b23d5f0e287211283615699e824ebc52f82245a8e25454b0b0801bfb063ba5b765b8bc722798baca83ce7e91c3895701ddc8e7d1a3
diff --git a/app-misc/regex-markup/files/regex-markup-0.10.0-locale.patch b/app-misc/regex-markup/files/regex-markup-0.10.0-locale.patch
new file mode 100644
index 000000000000..be9c74a66ceb
--- /dev/null
+++ b/app-misc/regex-markup/files/regex-markup-0.10.0-locale.patch
@@ -0,0 +1,29 @@
+ src/cacheline.c | 2 ++
+ src/remark.c | 1 +
+ 2 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/src/cacheline.c b/src/cacheline.c
+index 8c6f97b..f395c60 100644
+--- a/src/cacheline.c
++++ b/src/cacheline.c
+@@ -27,6 +27,8 @@
+ #include "getline.h" /* Gnulib/GNU Libc */
+ #include "version-etc.h" /* Gnulib */
+
++#include <locale.h>
++
+ enum {
+ HELP_OPT = 256,
+ VERSION_OPT
+diff --git a/src/remark.c b/src/remark.c
+index dcf8327..8998112 100644
+--- a/src/remark.c
++++ b/src/remark.c
+@@ -44,6 +44,7 @@
+ #include "common/intutil.h"
+ /* regex-markup */
+ #include "remark.h"
++#include <locale.h>
+
+ #define PROGRAM "remark"
+
diff --git a/app-misc/regex-markup/metadata.xml b/app-misc/regex-markup/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/app-misc/regex-markup/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/regex-markup/regex-markup-0.10.0.ebuild b/app-misc/regex-markup/regex-markup-0.10.0.ebuild
new file mode 100644
index 000000000000..b6ae39a6a8ec
--- /dev/null
+++ b/app-misc/regex-markup/regex-markup-0.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A tool to color syslog files as well"
+HOMEPAGE="http://www.nongnu.org/regex-markup/"
+SRC_URI="http://savannah.nongnu.org/download/regex-markup/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples nls"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-locale.patch
+}
+
+src_configure() {
+ econf \
+ --enable-largefile \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ if use examples; then
+ cd examples
+ emake -f Makefile
+ fi
+}