summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-10-19 21:56:07 +0200
committerSam James <sam@gentoo.org>2022-10-20 04:50:05 +0100
commit168b50a0f6e705286b28213f7c77f5421ec8b915 (patch)
treed3dfbc71c1076972282cb7cd97fdca8ad64e091b /app-misc/cw
parentsys-devel/make: add 4.3.91, drop 4.3.90 ("pretest", unkeyworded) (diff)
downloadgentoo-168b50a0f6e705286b28213f7c77f5421ec8b915.tar.gz
gentoo-168b50a0f6e705286b28213f7c77f5421ec8b915.tar.bz2
gentoo-168b50a0f6e705286b28213f7c77f5421ec8b915.zip
app-misc/cw: 1.0.16 revbump, fix build for clang16
Fixes: af397b3d6dec93a39eb752d80dd10695d654958a Closes: https://bugs.gentoo.org/870751 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/27857 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/cw')
-rw-r--r--app-misc/cw/cw-1.0.16-r5.ebuild (renamed from app-misc/cw/cw-1.0.16-r4.ebuild)9
-rw-r--r--app-misc/cw/files/cw-1.0.16-fix-configure-for-newer-autotools.patch10
2 files changed, 18 insertions, 1 deletions
diff --git a/app-misc/cw/cw-1.0.16-r4.ebuild b/app-misc/cw/cw-1.0.16-r5.ebuild
index b738753f2715..c66048665427 100644
--- a/app-misc/cw/cw-1.0.16-r4.ebuild
+++ b/app-misc/cw/cw-1.0.16-r5.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-inherit flag-o-matic toolchain-funcs
+WANT_AUTOMAKE="none"
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="A non-intrusive real-time ANSI color wrapper for common unix-based commands"
HOMEPAGE="http://cwrapper.sourceforge.net"
@@ -19,6 +20,7 @@ PATCHES=(
"${FILESDIR}"/${PV}-collision.patch
"${FILESDIR}"/${PV}-format-security.patch
"${FILESDIR}"/${P}-replace-isastream-with-fcntl.patch
+ "${FILESDIR}"/${P}-fix-configure-for-newer-autotools.patch
)
src_unpack() {
@@ -27,6 +29,11 @@ src_unpack() {
gunzip "${S}"/man/*.gz || die
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
tc-export CC
diff --git a/app-misc/cw/files/cw-1.0.16-fix-configure-for-newer-autotools.patch b/app-misc/cw/files/cw-1.0.16-fix-configure-for-newer-autotools.patch
new file mode 100644
index 000000000000..038e30074371
--- /dev/null
+++ b/app-misc/cw/files/cw-1.0.16-fix-configure-for-newer-autotools.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -17,7 +17,6 @@ ORIG_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS -Wall"
+ AC_TRY_COMPILE(,[return 0;],AC_MSG_RESULT(yes),AC_MSG_RESULT(no);CFLAGS="$ORIG_CFLAGS")
+ AC_CONFIG_HEADER(config.h)
+-AC_REQUIRE([AC_HEADER_STDC])
+ AC_CHECK_LIB(util, openpty)
+ AC_CHECK_FILE("/dev/ptmx", AC_DEFINE(HAVE_DEV_PTMX, 1, Have /dev/ptmx.))
+ AC_CHECK_FUNCS(getpt isatty isxdigit openpty putenv regcomp setenv setproctitle setsid sigaction sscanf uname unsetenv vsnprintf waitpid)