summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-11-15 19:28:15 +0800
committerYixun Lan <dlan@gentoo.org>2024-11-17 17:44:16 +0800
commit7c1577a91be6ac224e677bf63e9ecfccdc086479 (patch)
tree6727b0edf77d478e6bf8b79dd081d58cc72c52ea /app-i18n
parentapp-i18n/librime: add 1.12.0 (diff)
downloadgentoo-7c1577a91be6ac224e677bf63e9ecfccdc086479.tar.gz
gentoo-7c1577a91be6ac224e677bf63e9ecfccdc086479.tar.bz2
gentoo-7c1577a91be6ac224e677bf63e9ecfccdc086479.zip
app-i18n/fcitx-rime: add 5.1.9
Closes: https://github.com/gentoo/gentoo/pull/39333 Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-rime/Manifest1
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-5.1.9.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-i18n/fcitx-rime/Manifest b/app-i18n/fcitx-rime/Manifest
index 7a4d116cb852..3895f539bd20 100644
--- a/app-i18n/fcitx-rime/Manifest
+++ b/app-i18n/fcitx-rime/Manifest
@@ -1,2 +1,3 @@
DIST fcitx-rime-0.3.2.tar.xz 40960 BLAKE2B 1c9185dd9d2912e74b9916916fed09a01c30e0867d93fe94e04d5324883783dddbdca0f553d80aa19e2e59d2ec8fd2a50a7f89118c22cb09310296292a566760 SHA512 8c6d845b0899d9b8b9b41b895abd5c1b8916856b71f529aabd08d1c27a2b09bb5a9343912d088da460c2e22da0a3ce759a34fd13099a149bb8cd1ff4eafe29f1
DIST fcitx-rime-5.1.8.tar.zst 61573 BLAKE2B a406603aa66146735e3009837e050d0c46446b449e865429a95cfeee361768d5ba0b77cdd5b674f3b90e63912222146c115ac07fd0ce88cf6aa04bcac3e4a602 SHA512 75b8be80bd5ddc509bfa631f8ed093d89afee2588665b2b7604745b7c0b52376c4d55b36e33b53086c9b63992bfbeaae6292fa3096ec8f9ff9222647ff52e98c
+DIST fcitx-rime-5.1.9.tar.zst 64335 BLAKE2B aac7f54cc5bf3617744d1f85c13ed402fd13c41c81b144225d49e6ddfc11b207d286bdf8f91ec8b7156bebc9af4c6c6c2badc3fe1747c35851d88b4574cdf651 SHA512 efffd620d960346b96333bc3403e1c8a25acc99103ba2c465a5c27bb32842497c64647af540af306d8e0bb6d9ac4fdf852db7911233564ea38ee3980098f7336
diff --git a/app-i18n/fcitx-rime/fcitx-rime-5.1.9.ebuild b/app-i18n/fcitx-rime/fcitx-rime-5.1.9.ebuild
new file mode 100644
index 000000000000..2e4ed6447552
--- /dev/null
+++ b/app-i18n/fcitx-rime/fcitx-rime-5.1.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake unpacker xdg
+
+MY_PN="fcitx5-rime"
+DESCRIPTION="Chinese RIME input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-rime"
+SRC_URI="https://download.fcitx-im.org/fcitx5/fcitx5-rime/fcitx5-rime-${PV}.tar.zst -> ${P}.tar.zst"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+DEPEND="
+ !app-i18n/fcitx-rime:4
+ >=app-i18n/fcitx-5.1.11:5
+ app-i18n/librime
+ app-i18n/rime-data
+ virtual/libintl
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules
+ sys-devel/gettext
+ virtual/pkgconfig
+"