summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/kanjipad/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/kanjipad/files')
-rw-r--r--app-i18n/kanjipad/files/kanjipad-2.0.0-cflags.patch19
-rw-r--r--app-i18n/kanjipad/files/kanjipad-2.0.0-underlinking.patch13
2 files changed, 32 insertions, 0 deletions
diff --git a/app-i18n/kanjipad/files/kanjipad-2.0.0-cflags.patch b/app-i18n/kanjipad/files/kanjipad-2.0.0-cflags.patch
new file mode 100644
index 000000000000..b1a6786bf17a
--- /dev/null
+++ b/app-i18n/kanjipad/files/kanjipad-2.0.0-cflags.patch
@@ -0,0 +1,19 @@
+diff --git a/Makefile b/Makefile
+index 4869923..0f7509c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-OPTIMIZE=-g -Wall
++OPTIMIZE=-Wall
+ #OPTIMIZE=-O2
+
+ GTKINC=$(shell pkg-config --cflags gtk+-2.0) -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED
+@@ -26,7 +26,7 @@ PACKAGE = kanjipad
+ VERSION = 2.0.0
+
+ OBJS = kpengine.o scoring.o util.o
+-CFLAGS = $(OPTIMIZE) $(GTKINC) -DFOR_PILOT_COMPAT -DKP_LIBDIR=\"$(LIBDIR)\" -DBINDIR=\"$(BINDIR)\"
++CFLAGS += $(OPTIMIZE) $(GTKINC) -DFOR_PILOT_COMPAT -DKP_LIBDIR=\"$(LIBDIR)\" -DBINDIR=\"$(BINDIR)\"
+
+ all: kpengine kanjipad jdata.dat
+
diff --git a/app-i18n/kanjipad/files/kanjipad-2.0.0-underlinking.patch b/app-i18n/kanjipad/files/kanjipad-2.0.0-underlinking.patch
new file mode 100644
index 000000000000..26fbcd765119
--- /dev/null
+++ b/app-i18n/kanjipad/files/kanjipad-2.0.0-underlinking.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 7e67d30..5bf53ba 100644
+--- a/Makefile
++++ b/Makefile
+@@ -40,7 +40,7 @@ kpengine: $(OBJS)
+ $(CC) -o kpengine $(OBJS) $(GLIBLIBS) $(LDFLAGS)
+
+ kanjipad: kanjipad.o padarea.o
+- $(CC) -o kanjipad kanjipad.o padarea.o $(GTKLIBS) $(LDFLAGS)
++ $(CC) -o kanjipad kanjipad.o padarea.o -lm $(GTKLIBS) $(LDFLAGS)
+
+ jdata.dat: jstroke/strokedata.h conv_jdata.pl
+ perl conv_jdata.pl < jstroke/strokedata.h > jdata.dat