summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-15 01:46:21 +0000
committerSam James <sam@gentoo.org>2022-01-15 01:46:21 +0000
commit1c4e48ea59c8e7783f02af81ee28c31ecbb628ab (patch)
tree39d468a57b0eca303041eed90cbe89055488c21a /app-emulation
parentsys-block/ndctl: drop no-op USE=bash-completion (diff)
downloadgentoo-1c4e48ea59c8e7783f02af81ee28c31ecbb628ab.tar.gz
gentoo-1c4e48ea59c8e7783f02af81ee28c31ecbb628ab.tar.bz2
gentoo-1c4e48ea59c8e7783f02af81ee28c31ecbb628ab.zip
app-emulation/libvirt: [QA] unconditionally install bash-completion files
See small file policy [0]. Users can use INSTALL_MASK if they want these files (previously was automagic). (This is one of very few of these left, yay!) [0] https://projects.gentoo.org/qa/policy-guide/installed-files.html#pg0301 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/libvirt-7.10.0-r3.ebuild (renamed from app-emulation/libvirt/libvirt-7.10.0-r2.ebuild)6
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild8
2 files changed, 9 insertions, 5 deletions
diff --git a/app-emulation/libvirt/libvirt-7.10.0-r2.ebuild b/app-emulation/libvirt/libvirt-7.10.0-r3.ebuild
index 14c31d413e2c..70c8985899f1 100644
--- a/app-emulation/libvirt/libvirt-7.10.0-r2.ebuild
+++ b/app-emulation/libvirt/libvirt-7.10.0-r3.ebuild
@@ -25,7 +25,7 @@ HOMEPAGE="https://www.libvirt.org/ https://gitlab.com/libvirt/libvirt/"
LICENSE="LGPL-2.1"
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/libvirt.org.asc
IUSE="
- apparmor audit bash-completion +caps dtrace firewalld fuse glusterfs
+ apparmor audit +caps dtrace firewalld fuse glusterfs
iscsi iscsi-direct +libvirtd lvm libssh lxc nfs nls numa openvz
parted pcap policykit +qemu rbd sasl selinux +udev
virtualbox +virt-network wireshark-plugins xen zfs
@@ -48,7 +48,6 @@ BDEPEND="
dev-perl/XML-XPath
dev-python/docutils
virtual/pkgconfig
- bash-completion? ( >=app-shells/bash-completion-2.0 )
verify-sig? ( sec-keys/openpgp-keys-libvirt )"
# gettext.sh command is used by the libvirt command wrappers, and it's
@@ -281,6 +280,9 @@ src_configure() {
--localstatedir="${EPREFIX}/var"
-Drunstatedir="${EPREFIX}/run"
-Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+
+ -Dbash_completion=enabled
+ -Dbash_completion_dir="$(get_bashcompdir)"
)
meson_src_configure
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index fa0d16f6ac3b..0129df7341ea 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,7 +25,7 @@ HOMEPAGE="https://www.libvirt.org/ https://gitlab.com/libvirt/libvirt/"
LICENSE="LGPL-2.1"
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/libvirt.org.asc
IUSE="
- apparmor audit bash-completion +caps dtrace firewalld fuse glusterfs
+ apparmor audit +caps dtrace firewalld fuse glusterfs
iscsi iscsi-direct +libvirtd lvm libssh lxc nfs nls numa openvz
parted pcap policykit +qemu rbd sasl selinux +udev
virtualbox +virt-network wireshark-plugins xen zfs
@@ -48,7 +48,6 @@ BDEPEND="
dev-perl/XML-XPath
dev-python/docutils
virtual/pkgconfig
- bash-completion? ( >=app-shells/bash-completion-2.0 )
verify-sig? ( sec-keys/openpgp-keys-libvirt )"
# gettext.sh command is used by the libvirt command wrappers, and it's
@@ -279,6 +278,9 @@ src_configure() {
--localstatedir="${EPREFIX}/var"
-Drunstatedir="${EPREFIX}/run"
-Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+
+ -Dbash_completion=enabled
+ -Dbash_completion_dir="$(get_bashcompdir)"
)
meson_src_configure