summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-10-08 10:42:16 +0200
committerUlrich Müller <ulm@gentoo.org>2021-10-08 10:42:41 +0200
commit016bcebec76fa373428c3c50d7477da941e5dccc (patch)
treea117d6de8a0f2b70757c5d4722a3c40d7d7eb051 /app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild
parentapp-emacs/yasnippet: Version bump to 0.14.0 (diff)
downloadgentoo-016bcebec76fa373428c3c50d7477da941e5dccc.tar.gz
gentoo-016bcebec76fa373428c3c50d7477da941e5dccc.tar.bz2
gentoo-016bcebec76fa373428c3c50d7477da941e5dccc.zip
app-emacs/yasnippet-snippets: Version bump to 1.0
Closes: https://bugs.gentoo.org/816936 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild')
-rw-r--r--app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild b/app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild
new file mode 100644
index 000000000000..3b0d29b244e7
--- /dev/null
+++ b/app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A collection of yasnippet snippets for many languages"
+HOMEPAGE="https://github.com/AndreaCrotti/yasnippet-snippets"
+SRC_URI="https://github.com/AndreaCrotti/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/yasnippet"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() { :; }
+
+src_install() {
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ insinto "${SITEETC}/${PN}"
+ doins -r snippets/.
+ dodoc README.md
+}