summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-06 20:23:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-06 21:51:30 +0200
commite30781ce00ff61c2e9ff057e575e7a00fcadb82e (patch)
treeb4ff8a533f8ea8739b2d4967b8b4d8b00ffc3612 /app-emacs/groovy-emacs-modes
parentapp-emacs/ht: minor tweaks (diff)
downloadgentoo-e30781ce00ff61c2e9ff057e575e7a00fcadb82e.tar.gz
gentoo-e30781ce00ff61c2e9ff057e575e7a00fcadb82e.tar.bz2
gentoo-e30781ce00ff61c2e9ff057e575e7a00fcadb82e.zip
app-emacs/groovy-emacs-modes: minor tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/groovy-emacs-modes')
-rw-r--r--app-emacs/groovy-emacs-modes/groovy-emacs-modes-2.1.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/app-emacs/groovy-emacs-modes/groovy-emacs-modes-2.1.ebuild b/app-emacs/groovy-emacs-modes/groovy-emacs-modes-2.1.ebuild
index 335b5554baa3..3bceb207d749 100644
--- a/app-emacs/groovy-emacs-modes/groovy-emacs-modes-2.1.ebuild
+++ b/app-emacs/groovy-emacs-modes/groovy-emacs-modes-2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,14 +7,20 @@ inherit elisp
DESCRIPTION="Groovy major mode, grails minor mode, and a groovy inferior mode"
HOMEPAGE="https://github.com/Groovy-Emacs-Modes/groovy-emacs-modes/"
-SRC_URI="https://github.com/Groovy-Emacs-Modes/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Groovy-Emacs-Modes/${PN}.git"
+else
+ SRC_URI="https://github.com/Groovy-Emacs-Modes/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="amd64 ~x86"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
DOCS=( README.md groovy-mode.png )
SITEFILE="50${PN}-gentoo.el"
@@ -26,18 +32,15 @@ RDEPEND="
BDEPEND="
${RDEPEND}
test? (
- app-emacs/ert-runner
app-emacs/f
app-emacs/shut-up
app-emacs/undercover
)
"
+elisp-enable-tests ert-runner test
+
src_compile() {
elisp_src_compile
elisp-make-autoload-file
}
-
-src_test() {
- ert-runner -L . -L test --reporter ert+duration --script test || die
-}