summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-01-12 11:48:35 -0300
committerMatt Turner <mattst88@gentoo.org>2023-01-12 14:32:43 -0500
commit7663b20b4d1205b29f501a889c232c924ecfbfa2 (patch)
tree21bb3641288ffcf41e795813541303cbb489c1ca /app-editors/gnome-text-editor
parentgui-libs/gtksourceview: Version bump to 5.6.2 (diff)
downloadgentoo-7663b20b4d1205b29f501a889c232c924ecfbfa2.tar.gz
gentoo-7663b20b4d1205b29f501a889c232c924ecfbfa2.tar.bz2
gentoo-7663b20b4d1205b29f501a889c232c924ecfbfa2.zip
app-editors/gnome-text-editor: Version bump to 43.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29076 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/gnome-text-editor')
-rw-r--r--app-editors/gnome-text-editor/Manifest1
-rw-r--r--app-editors/gnome-text-editor/gnome-text-editor-43.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-editors/gnome-text-editor/Manifest b/app-editors/gnome-text-editor/Manifest
index 68a0d0c48fb7..7c9d1a7757a3 100644
--- a/app-editors/gnome-text-editor/Manifest
+++ b/app-editors/gnome-text-editor/Manifest
@@ -1 +1,2 @@
DIST gnome-text-editor-43.1.tar.xz 601588 BLAKE2B 0e3b7231327898b554360cfa45c3ba9f8ff005f61b6f68f6ea431d1c9e459b429af4da794b06ce6f4618de06c96a191477f1cadd61cfa6ae9e1ae350b75658a1 SHA512 aab2fcf5d0ad705833802bec3ccacce175c16dc717b521e0b220ddf5420760ec76a90db9b4f4ee0722c2b19a40304e1c379f06f2983e4597df233ade67a0f725
+DIST gnome-text-editor-43.2.tar.xz 611536 BLAKE2B d2230dee0b858384af9c9138631262eca27c0d79d9fc9dbf0a19206e325691326c1a8f80dee5ee4ade6f023b2cf91f10425eb522beed72bc41768645ca8200bc SHA512 b5fd2b5605b6ded13f0bcb684e543f8cd5fae0ec28f713d5cb45e07e5e17115632595d83e2ecbb37b7fba2eec887c11da2ea8d17b842de75ce1c4e27a0f17187
diff --git a/app-editors/gnome-text-editor/gnome-text-editor-43.2.ebuild b/app-editors/gnome-text-editor/gnome-text-editor-43.2.ebuild
new file mode 100644
index 000000000000..7342df1f209b
--- /dev/null
+++ b/app-editors/gnome-text-editor/gnome-text-editor-43.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple text editor for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-text-editor"
+S="${WORKDIR}/gnome-text-editor-${PV/_/.}"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="spell"
+
+KEYWORDS="~amd64 ~riscv"
+
+DEPEND="
+ >=dev-libs/glib-2.73.0:2
+ >=gui-libs/gtk-4.7:4
+ >=gui-libs/gtksourceview-5.5.0:5
+ >=gui-libs/libadwaita-1.2:1
+ app-text/editorconfig-core-c
+ spell? (
+ >=app-text/enchant-2.2.0:2
+ dev-libs/icu:=
+ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.21
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature spell enchant)
+ -Dbugreport_url="https://bugs.gentoo.org"
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}