summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-09-06 12:37:23 -0500
committerAustin English <wizardedit@gentoo.org>2017-10-05 12:23:03 -0500
commit2c808eedc775a1f663cd61afa87e070c68c69faa (patch)
treedbaa8d4adf4f18704fc6c2265504adb83edbd462 /app-crypt
parentdev-libs/libisoburn: Version bump. (diff)
downloadgentoo-2c808eedc775a1f663cd61afa87e070c68c69faa.tar.gz
gentoo-2c808eedc775a1f663cd61afa87e070c68c69faa.tar.bz2
gentoo-2c808eedc775a1f663cd61afa87e070c68c69faa.zip
app-crypt/seahorse: add upstream patch allowing building with GnuPG 2.2.0
Also sort DEPENDS https://bugs.gentoo.org/629864 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse/files/seahorse-3.20.0-gnupg-configure.patch32
-rw-r--r--app-crypt/seahorse/seahorse-3.20.0-r1.ebuild67
2 files changed, 99 insertions, 0 deletions
diff --git a/app-crypt/seahorse/files/seahorse-3.20.0-gnupg-configure.patch b/app-crypt/seahorse/files/seahorse-3.20.0-gnupg-configure.patch
new file mode 100644
index 000000000000..6c81974c4fd3
--- /dev/null
+++ b/app-crypt/seahorse/files/seahorse-3.20.0-gnupg-configure.patch
@@ -0,0 +1,32 @@
+From 31a9a6ffc10f9737e70d7f0051ff590ff284ad07 Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Tue, 5 Sep 2017 00:01:16 +0200
+Subject: Accept GnuPG 2.2.x as supported version
+
+https://git.gnome.org/browse/seahorse/commit/?id=31a9a6ffc10f9737e70d7f0051ff590ff284ad07
+https://git.gnome.org/browse/seahorse/patch/?id=31a9a6ffc10f9737e70d7f0051ff590ff284ad07
+
+Note: had to change GPGME_REQUIRED=1.7.0 to GPGME_REQUIRED=1.0.0 for
+3.20.0 for patch to apply
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index fc4493c..723b46f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -9,7 +9,7 @@ GCR_REQUIRED=3.11.91
+ GTK_REQ=3.4.0
+ GTK_MAX=GTK_VERSION_3_4
+
+-GNUPG_ACCEPTED="2.0.12 2.1.4"
++GNUPG_ACCEPTED="2.0.12 2.1.4 2.2.0"
+ GPGME_REQUIRED=1.0.0
+ LIBSECRET_REQUIRED=0.16
+ AVAHI_GLIB_REQUIRED=0.6
+--
+cgit v0.12
+
+
diff --git a/app-crypt/seahorse/seahorse-3.20.0-r1.ebuild b/app-crypt/seahorse/seahorse-3.20.0-r1.ebuild
new file mode 100644
index 000000000000..3b0fd9101ded
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-3.20.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_EAUTORECONF="yes"
+inherit gnome2
+
+DESCRIPTION="A GNOME application for managing encryption keys"
+HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE="debug ldap zeroconf"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.11.91:=
+ >=app-crypt/gnupg-2.0.12
+ >=app-crypt/gpgme-1
+ >=app-crypt/libsecret-0.16
+ >=dev-libs/glib-2.10:2
+ >=net-libs/libsoup-2.33.92:2.4
+ net-misc/openssh
+ >=x11-libs/gtk+-3.4:3
+ x11-misc/shared-mime-info
+
+ ldap? ( net-nds/openldap:= )
+ zeroconf? ( >=net-dns/avahi-0.6:= )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-util/gdbus-codegen
+ >=dev-util/intltool-0.35
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# Need seahorse-plugins git snapshot
+RDEPEND="${COMMON_DEPEND}
+ !<app-crypt/seahorse-plugins-2.91.0_pre20110114
+"
+
+src_prepare() {
+ # Bug #629864
+ eapply "${FILESDIR}/seahorse-3.20.0-gnupg-configure.patch"
+
+ # Do not mess with CFLAGS with USE="debug"
+ sed -e '/CFLAGS="$CFLAGS -g/d' \
+ -e '/CFLAGS="$CFLAGS -O0/d' \
+ -i.bak configure.ac || die "sed 1 failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # bindir is needed due to bad macro expansion in desktop file, bug #508610
+ gnome2_src_configure \
+ --bindir=/usr/bin \
+ --enable-pgp \
+ --enable-ssh \
+ --enable-pkcs11 \
+ --enable-hkp \
+ $(use_enable debug) \
+ $(use_enable ldap) \
+ $(use_enable zeroconf sharing) \
+ VALAC=$(type -P true)
+}