summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2016-07-01 19:04:03 +0200
committerAmy Winston <amynka@gentoo.org>2016-07-01 19:04:03 +0200
commit99bc8b5524ba2542b22b81c8d5c1a4b431c23573 (patch)
treead896d438d49776c777a2b2500c8cfad1126a17a /app-crypt/eid-mw/eid-mw-9999.ebuild
parentdev-ruby/octokit: add missing test dep on mime-types (diff)
downloadgentoo-99bc8b5524ba2542b22b81c8d5c1a4b431c23573.tar.gz
gentoo-99bc8b5524ba2542b22b81c8d5c1a4b431c23573.tar.bz2
gentoo-99bc8b5524ba2542b22b81c8d5c1a4b431c23573.zip
app-crypt/eid-mw: eapi update bug #587250 by Vincent Hardy
- Move to EAPI 6 - add 1 new dependency - patch update gtk_not_required_9999.patch - add new patch not_zip_xpi_plugin.patch - add missing die Package-Manager: portage-2.2.28
Diffstat (limited to 'app-crypt/eid-mw/eid-mw-9999.ebuild')
-rw-r--r--app-crypt/eid-mw/eid-mw-9999.ebuild38
1 files changed, 25 insertions, 13 deletions
diff --git a/app-crypt/eid-mw/eid-mw-9999.ebuild b/app-crypt/eid-mw/eid-mw-9999.ebuild
index 2424341373a5..57bb7b83b7df 100644
--- a/app-crypt/eid-mw/eid-mw-9999.ebuild
+++ b/app-crypt/eid-mw/eid-mw-9999.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit eutils autotools mozextension multilib
+inherit autotools mozextension
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/Fedict/${PN}.git
https://github.com/Fedict/${PN}.git"
- inherit git-2
+ inherit git-r3
SRC_URI=""
else
MY_P="${P}-v${PV}"
@@ -29,8 +29,9 @@ IUSE="+gtk +xpi +dialogs"
REQUIRED_USE="
dialogs? ( gtk )"
-RDEPEND="gtk? ( x11-libs/gtk+:* )
+RDEPEND="gtk? ( x11-libs/gtk+:= )
>=sys-apps/pcsc-lite-1.2.9
+ net-libs/libproxy
xpi? ( || ( >=www-client/firefox-bin-3.6.24
>=www-client/firefox-3.6.20 ) )
!app-misc/beid-runtime"
@@ -39,21 +40,32 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
- use gtk || epatch "${FILESDIR}"/gtk_not_required_9999.patch
+ eapply_user
if [[ ${PV} == "9999" ]] ; then
+ use gtk || eapply "${FILESDIR}"/gtk_not_required_9999.patch
+
# Only in current git. Hopefully, in next release.
- sed -i -e 's:/beid/rsaref220:/rsaref220:' configure.ac
- sed -i -e 's:/beid::' cardcomm/pkcs11/src/libbeidpkcs11.pc.in
+ sed -i -e 's:/beid/rsaref220:/rsaref220:' configure.ac || die
+ sed -i -e 's:/beid::' cardcomm/pkcs11/src/libbeidpkcs11.pc.in || die
+ else
+ use gtk || eapply "${FILESDIR}"/gtk_not_required_4.1.4.patch
fi
if [[ ${PV} == "9999" ]] || ! use gtk ; then
eautoreconf
fi
+
+ # Do that after autoreconf (if autoreconf is required)
+ # This patch is not mandatory, it's just to do things properly :-)
+ eapply "${FILESDIR}"/not_zip_xpi_plugin.patch
}
src_configure() {
- econf $(use_enable dialogs) --disable-static
+ econf \
+ $(use_enable dialogs) \
+ --disable-static \
+ --disable-signed
}
src_install() {
@@ -61,19 +73,19 @@ src_install() {
if [[ ${PV} != "9999" ]] ; then
# Automatically done in current git. Hopefully, in next release.
- rm doc/sdk/include/rsaref220/win32.h
+ rm doc/sdk/include/rsaref220/win32.h || die
doheader -r doc/sdk/include/*
fi
if use xpi; then
declare MOZILLA_FIVE_HOME
if has_version '>=www-client/firefox-3.6.20'; then
MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
- xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
fi
if has_version '>=www-client/firefox-bin-3.6.24'; then
MOZILLA_FIVE_HOME="/opt/firefox"
- xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
fi
fi
- rm -r "${D}/usr/share" "${D}"/usr/lib*/*.la
+ rm -r "${D}/usr/share" "${D}"/usr/lib*/*.la || die
}