summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-04-14 12:27:45 -0700
committerZac Medico <zmedico@gentoo.org>2024-04-14 12:42:05 -0700
commite85fee1101fc083159109f10a6cdf9a242280e4f (patch)
treebe9eb8855ac553f9abfcea0393c82ea2c91ac6e6 /app-containers/containers-common
parentdev-texlive/texlive-langcjk: add weak blocker for <texlive-xetex-2023 (diff)
downloadgentoo-e85fee1101fc083159109f10a6cdf9a242280e4f.tar.gz
gentoo-e85fee1101fc083159109f10a6cdf9a242280e4f.tar.bz2
gentoo-e85fee1101fc083159109f10a6cdf9a242280e4f.zip
app-containers/containers-common: 0.57.0-r1 stable revbump resolves file collisions
Use a 0.57.0-r1 stable revbump to resolve file collisions with app-containers/containers-image-5.29.2-r1 which was stabilized for bug 921771. These files have migrated to containers-image: /etc/containers/policy.json /etc/containers/registries.d/default.yaml This file is no longer installed but there is another copy installed in /usr/share/containers: /etc/containers/containers.conf Closes: https://bugs.gentoo.org/930027 Bug: https://bugs.gentoo.org/921771 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers/containers-common')
-rw-r--r--app-containers/containers-common/containers-common-0.57.0-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-containers/containers-common/containers-common-0.57.0-r1.ebuild b/app-containers/containers-common/containers-common-0.57.0-r1.ebuild
new file mode 100644
index 000000000000..3cb764cb31ce
--- /dev/null
+++ b/app-containers/containers-common/containers-common-0.57.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Common config files and docs for Containers stack"
+HOMEPAGE="https://github.com/containers/common"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/common.git"
+else
+ SRC_URI="https://github.com/containers/common/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="amd64 arm64 ~riscv"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+RESTRICT="test"
+RDEPEND="
+ >=app-containers/containers-image-5.29.2
+ app-containers/containers-storage
+ app-containers/containers-shortnames
+ !<app-containers/podman-4.5.0-r1
+ net-firewall/nftables
+ net-firewall/iptables[nftables]
+ || ( app-containers/crun app-containers/runc )
+ || (
+ ( >=app-containers/netavark-1.6.0 >=app-containers/aardvark-dns-1.6.0 )
+ >=app-containers/cni-plugins-0.9.1
+ )
+"
+
+BDEPEND="
+ >=dev-go/go-md2man-2.0.2
+"
+
+src_prepare() {
+ default
+
+ [[ -f docs/Makefile && -f Makefile ]] || die
+ sed -i -e 's|/usr/local|/usr|g;' docs/Makefile Makefile || die
+
+ # add comments to mounts.conf
+ eapply "${FILESDIR}/examplify-mounts-conf.patch"
+}
+
+src_compile() {
+ emake docs
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ insinto /usr/share/containers
+ doins pkg/seccomp/seccomp.json pkg/subscriptions/mounts.conf
+
+ keepdir /etc/containers/certs.d /etc/containers/oci/hooks.d /etc/containers/systemd /var/lib/containers/sigstore
+}