summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/extract-xiso
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/extract-xiso')
-rw-r--r--app-cdr/extract-xiso/Manifest1
-rw-r--r--app-cdr/extract-xiso/extract-xiso-2.5.ebuild38
-rw-r--r--app-cdr/extract-xiso/metadata.xml9
3 files changed, 48 insertions, 0 deletions
diff --git a/app-cdr/extract-xiso/Manifest b/app-cdr/extract-xiso/Manifest
new file mode 100644
index 000000000000..6ac3eba81a08
--- /dev/null
+++ b/app-cdr/extract-xiso/Manifest
@@ -0,0 +1 @@
+DIST extract-xiso_v2.5_src.tgz 207052 SHA256 056bae1d970a1907aebebc796724fc82debac72010e8227f9ce5a470f16714d7 SHA512 ae73d5814167894f60530f9cb88485a9bcc39a60da87ed20b8b579f8e3f91542df102c2f9cb868ce61ff61c1a5add63d4bec66097f039c906353762358760dec WHIRLPOOL e59664007267ed5daa927e5669bb32050618af7282d5f672b2829c0782a9e8c4bc2da55534c7a4339defab14671e75d8c47d1fde0730874a9cf13486f47a1140
diff --git a/app-cdr/extract-xiso/extract-xiso-2.5.ebuild b/app-cdr/extract-xiso/extract-xiso-2.5.ebuild
new file mode 100644
index 000000000000..f2b3d5452bb5
--- /dev/null
+++ b/app-cdr/extract-xiso/extract-xiso-2.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+MY_PV=${PV/_beta/b}
+
+DESCRIPTION="Tool for extracting and creating optimised Xbox ISO images"
+HOMEPAGE="http://sourceforge.net/projects/extract-xiso"
+SRC_URI="mirror://sourceforge/extract-xiso/${PN}_v${MY_PV}_src.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:__LINUX__:__linux__:' \
+ *.[ch] */*.[ch] || die
+}
+
+doit() { echo "$@"; "$@"; }
+
+src_compile() {
+ doit $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} \
+ extract-xiso.c libftp-*/*.c -o extract-xiso || die
+}
+
+src_install() {
+ dobin extract-xiso || die
+ dodoc README.TXT
+}
diff --git a/app-cdr/extract-xiso/metadata.xml b/app-cdr/extract-xiso/metadata.xml
new file mode 100644
index 000000000000..ca3c1304c920
--- /dev/null
+++ b/app-cdr/extract-xiso/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>xbox</herd>
+ <longdescription>Tool for extracting and creating optimised Xbox ISO images</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">extract-xiso</remote-id>
+ </upstream>
+</pkgmetadata>