summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2017-09-20 19:59:36 +0000
committerPatrice Clement <monsieurp@gentoo.org>2017-10-04 00:07:25 +0200
commitc1386924e0fea7b6fad54e3d38a6d8fa9390e31f (patch)
tree7b591269fc02aa42e7988023652d5a91ca701d69 /app-backup
parentapp-backup/restic: clean up old. (diff)
downloadgentoo-c1386924e0fea7b6fad54e3d38a6d8fa9390e31f.tar.gz
gentoo-c1386924e0fea7b6fad54e3d38a6d8fa9390e31f.tar.bz2
gentoo-c1386924e0fea7b6fad54e3d38a6d8fa9390e31f.zip
app-backup/restic: version bump to 0.7.3.
Closes: https://bugs.gentoo.org/631112 Closes: https://github.com/gentoo/gentoo/pull/5742
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/restic/Manifest1
-rw-r--r--app-backup/restic/restic-0.7.3.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-backup/restic/Manifest b/app-backup/restic/Manifest
index 638654700ee8..04e2f4c277df 100644
--- a/app-backup/restic/Manifest
+++ b/app-backup/restic/Manifest
@@ -1,2 +1,3 @@
DIST restic-0.6.1.tar.gz 25231223 SHA256 7cd709c592a5978723673397d7d13c37c0977e20c43db253d0c274b53a55654a SHA512 8c899ca8b6e3dfa399fe5c4306f72a1bcfa869dd667d27f3f88efa26aaa1000959bf91b515911b2ef7b2d4c5bb3e2ed4f202c87add7766d2147b7d40f0757a9a WHIRLPOOL 39225876fd6ce9e4ddac765688238ab5ea430272aacc6e96d54c359de939d2e69cdc45a5571cb63777c258a74b5a9bfbd6114d2463004b242b009856d87b6e2e
DIST restic-0.7.1.tar.gz 25438170 SHA256 81efde662c34225b5705f3d72daa1f6278455c2b8f786224d7a1ecca0b14efca SHA512 3b887149c801fe81f9bf65e0ae4a17ba97f66c0133f45b3f5526d79d580f072e0e5fd89cd78a5018992dc42e6dafb9385139f4336fe6f06d57d8abe7a9e323b1 WHIRLPOOL bbdeafadd7b329147b7ea30b13d806d20de76e8efcc1ace4eea74420aa39f6d7a8f5eb186169d2a053988d07d44063ca71c54287aa07c4cd4cdc906a07b80dc7
+DIST restic-0.7.3.tar.gz 37062625 SHA256 6d795a5f052b3a8cb8e7571629da14f00e92035b7174eb20e32fd1440f68aaff SHA512 2d44b4fc363c7f6389c1f06469cf30ebeff4d6ade0bd4fcae1d7d9def3922936b45043b04f4072284b773df2c6487c58db6aea41c7de5c8184ca33ca3c44d44a WHIRLPOOL dde430e4d718928b01da0f1558fd8a7bf65a0d9e3a4a620cc7557e6afd4760a8dc6c1a9d7c744649cb817b99fb22ee2e2f893d5fd49fa961d5ab6b8bb02941b0
diff --git a/app-backup/restic/restic-0.7.3.ebuild b/app-backup/restic/restic-0.7.3.ebuild
new file mode 100644
index 000000000000..b9393fcd9266
--- /dev/null
+++ b/app-backup/restic/restic-0.7.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="A backup program that is fast, efficient and secure"
+HOMEPAGE="https://restic.github.io/"
+SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGO_PN="github.com/restic/restic"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+DOCS=(
+ README.rst CONTRIBUTING.md doc/design.rst
+ doc/faq.rst doc/index.rst doc/manual.rst
+ doc/rest_backend.rst doc/development.rst
+ doc/talks.rst doc/tutorial_aws_s3.rst doc/installation.rst
+)
+
+DEPEND="
+ dev-lang/go
+ test? ( sys-fs/fuse:0 )"
+
+RDEPEND="sys-fs/fuse:0"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ local mygoargs=(
+ -v
+ -work
+ -x
+ -tags release
+ -ldflags "-s -w -X main.version=${PV}"
+ -asmflags "-trimpath=${S}"
+ -gcflags "-trimpath=${S}"
+ -o restic ${EGO_PN}/cmd/restic
+ )
+
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go build "${mygoargs[@]}" || die
+}
+
+src_test() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go test -timeout 30m -v -work -x ${EGO_PN}/cmd/... ${EGO_PN}/internal/... || die
+}
+
+src_install() {
+ dobin restic
+ einstalldocs
+
+ local i
+ for i in doc/man/*; do
+ doman "$i"
+ done
+}