summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Ayodele <folajimi@post.com>2023-02-07 21:49:12 -0500
committerSam James <sam@gentoo.org>2023-02-08 03:29:31 +0000
commitbad6b5a6a0e8219e7ab9c7d2830c464b1ea74426 (patch)
treed0696872c3339d5e9502573b24915f48c960de46 /app-backup
parentdev-libs/xmlsec: Stabilize 1.2.37 arm64, #893572 (diff)
downloadgentoo-bad6b5a6a0e8219e7ab9c7d2830c464b1ea74426.tar.gz
gentoo-bad6b5a6a0e8219e7ab9c7d2830c464b1ea74426.tar.bz2
gentoo-bad6b5a6a0e8219e7ab9c7d2830c464b1ea74426.zip
app-backup/rsnapshot: add 1.4.5
Signed-off-by: Jimi Ayodele <folajimi@post.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/rsnapshot/Manifest1
-rw-r--r--app-backup/rsnapshot/rsnapshot-1.4.5.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-backup/rsnapshot/Manifest b/app-backup/rsnapshot/Manifest
index d13e263d3056..75493f31e8eb 100644
--- a/app-backup/rsnapshot/Manifest
+++ b/app-backup/rsnapshot/Manifest
@@ -1 +1,2 @@
DIST rsnapshot-1.4.4.tar.gz 374269 BLAKE2B 1e4a0c99d12d48cf4dacd3817b621f7e6b0ba32e9d9de87b61252875ae0bf735e8ce2c7d8bb60edb2f7d6345a06b183a2616bf1ac3dd7d1b5d3a3ef22a0ede6f SHA512 da45039457b9f3feb53b823f6ee36e8f7447d0689281d1bc857c6fedd450db2fdf8a98e66ba6e135a86654666888f7744ad9ff0aabbd605e1fc09dd5f1f7b838
+DIST rsnapshot-1.4.5.tar.gz 287731 BLAKE2B 2a668aa16991b2b4e611c6204cdcd0e8c9593e5f0af5ea89e787a578e73b6f5987514cd7d0252bb78aea1b157ef85aea947686111ca9e3befdb2a8cef0aa9ecd SHA512 6caa2d7c425d084d0bb393421a0ed1ba78fdd27f7d8cec4810bc4a9f88b3232aeff7e4682282178f7702e2adc7abc8e9201249bf2bcaa28faa16e30aaa62e18a
diff --git a/app-backup/rsnapshot/rsnapshot-1.4.5.ebuild b/app-backup/rsnapshot/rsnapshot-1.4.5.ebuild
new file mode 100644
index 000000000000..52d1d54e786b
--- /dev/null
+++ b/app-backup/rsnapshot/rsnapshot-1.4.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A filesystem backup utility based on rsync"
+HOMEPAGE="https://www.rsnapshot.org"
+SRC_URI="https://www.rsnapshot.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-lang/perl-5.8.2
+ dev-perl/Lchown
+ >=sys-apps/util-linux-2.12-r4
+ >=sys-apps/coreutils-5.0.91-r4
+ >=net-misc/openssh-3.7.1_p2-r1
+ >=net-misc/rsync-2.6.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # remove '/etc/' since we don't place it here, bug #461554
+ sed -i -e 's:/etc/rsnapshot.conf.default:rsnapshot.conf.default:' rsnapshot-program.pl || die
+}
+
+src_install() {
+ docompress -x "/usr/share/doc/${PF}/rsnapshot.conf.default"
+
+ # Change sysconfdir to install the template file as documentation
+ # rather than in /etc.
+ emake install DESTDIR="${D}" \
+ sysconfdir="${EPREFIX}/usr/share/doc/${PF}"
+
+ dodoc README.md AUTHORS ChangeLog \
+ docs/Upgrading_from_1.1
+
+ docinto utils
+ dodoc utils/{README,rsnaptar,*.sh,*.pl}
+
+ docinto utils/rsnapshotdb
+ dodoc utils/rsnapshotdb/*
+}
+
+pkg_postinst() {
+ elog "The template configuration file has been installed as"
+ elog " ${EROOT}/usr/share/doc/${PF}/rsnapshot.conf.default"
+ elog "Copy and edit the the above file as ${EROOT}/etc/rsnapshot.conf"
+}