summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/afio/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/afio/files')
-rw-r--r--app-arch/afio/files/Makefile-r1.patch23
-rw-r--r--app-arch/afio/files/Makefile.patch25
2 files changed, 48 insertions, 0 deletions
diff --git a/app-arch/afio/files/Makefile-r1.patch b/app-arch/afio/files/Makefile-r1.patch
new file mode 100644
index 000000000000..70ec6caa4b90
--- /dev/null
+++ b/app-arch/afio/files/Makefile-r1.patch
@@ -0,0 +1,23 @@
+diff -urN afio-2.5.1.orig/Makefile afio-2.5.1/Makefile
+--- afio-2.5.1.orig/Makefile 2012-02-05 14:52:24.000000000 +0100
++++ afio-2.5.1/Makefile 2012-03-11 14:02:16.267636685 +0100
+@@ -71,15 +71,12 @@
+ MW=
+ #MW=-Wtraditional -Wcast-qual -Wcast-align -Wconversion -pedantic -Wlong-long -Wimplicit -Wuninitialized -W -Wshadow -Wsign-compare -Wstrict-prototypes -Wmissing-declarations
+
+-CFLAGS1 = -Wall -Wstrict-prototypes -s -O2 -fomit-frame-pointer ${LARGEFILEFLAGS} ${MW}
+-
+-CC=gcc
+-
+-CFLAGS = ${CFLAGS1} $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e ${e2} $f $g $I
+-LDFLAGS =
++CC?=gcc
++CFLAGS+=-Wall -Wstrict-prototypes -s ${LARGEFILEFLAGS} ${2} ${3} ${6} ${8} ${c} ${d} ${e2} ${f} ${g}
++LDFLAGS+=
+
+ afio : afio.o compfile.o exten.o match.o $M
+- ${CC} ${LDFLAGS} afio.o compfile.o exten.o match.o $M -o afio
++ ${CC} ${CFLAGS} ${LDFLAGS} afio.o compfile.o exten.o match.o $M -o afio
+
+ clean:
+ rm -f *.o afio
diff --git a/app-arch/afio/files/Makefile.patch b/app-arch/afio/files/Makefile.patch
new file mode 100644
index 000000000000..537c29939fa2
--- /dev/null
+++ b/app-arch/afio/files/Makefile.patch
@@ -0,0 +1,25 @@
+--- Makefile.orig 2003-11-10 00:11:50.000000000 -0800
++++ Makefile 2003-11-10 00:13:47.000000000 -0800
+@@ -1,4 +1,22 @@
+ SHELL=/bin/sh
++1=
++2=
++3=
++4=
++5=
++6=
++7=
++8=
++9=
++a=
++b=
++c=
++d=
++e=
++f=
++g=
++M=
++I=
+ ##
+ ## I wrote this Makefile, based on comments in the source. -rich $alz.
+ ## Define INDEX to use index() in place of strchr() (v7, BSD).