summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-21 04:36:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-21 04:36:05 +0200
commit31c0dde96350f8ed601a62fb4523efb6db4314b3 (patch)
tree5e81c32f871e1bbea4064117575d9085be45f464 /app-admin
parentdev-python/boto3: Bump to 1.28.68 (diff)
downloadgentoo-31c0dde96350f8ed601a62fb4523efb6db4314b3.tar.gz
gentoo-31c0dde96350f8ed601a62fb4523efb6db4314b3.tar.bz2
gentoo-31c0dde96350f8ed601a62fb4523efb6db4314b3.zip
app-admin/awscli: Bump to 1.29.68
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.29.68.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index c396050dd952..f590dbb0b410 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -7,3 +7,4 @@ DIST aws-cli-1.29.64.gh.tar.gz 2561807 BLAKE2B a4423549d6bd5789ebbd027febc411a7a
DIST aws-cli-1.29.65.gh.tar.gz 2562601 BLAKE2B 4c88ae2dcd37685f6908e027dc960d14e08f268f4f0784763b2e371f598d848c055847e27540c14d1ac745e4d87ce894e1e5a375c46ea522c384cb377146816a SHA512 b2bbcb989602be9b4f513cf8c0feddd2c680d005568d0f82a82206ebf13f2235fd0650d85502738bd0f2410e5a006d14fafa1873b7d9ba453843e8f055985a51
DIST aws-cli-1.29.66.gh.tar.gz 2563105 BLAKE2B 547b401269b8ea5431c3ff831c513306fa4d4c9fe21a15cba74528e460e626b900f0e29ddcb93c6735d1b85f8ad89528de576a87c0bcc2f31147f047add2449d SHA512 1114e1c2279d59ee1396716ccc619e8073ff425c1eaa88cf7ee5274ebfac0361646ad8d17a4a4bc565714e5dbd6537767d91ea039fa163761cb7f38c20760c24
DIST aws-cli-1.29.67.gh.tar.gz 2564759 BLAKE2B d73e71c37372a2bef0c2338b38d67f52e15619d3611cd664111d173e31e8ab9b3d87dbd0d1e94f7df3cbb0005410dadc748c95042143c7a0822705318e1ac25c SHA512 c9651ba2db96e4823aa7a3cdc9a3632f666dc3589e15f16c82fce7eb9b21a59468912f330255b379b47dec0c25c5c9d05536e61f4036a64259534860081e8e5b
+DIST aws-cli-1.29.68.gh.tar.gz 2565226 BLAKE2B b1f2209738c3a54beac322b14ceb54d31a4288b85038c2778d56d8dcafbabe7a307aa228c96e73faabc0ad2495edb65f701a35eddc506c70f0873f9084177c36 SHA512 d8cafa7560ab0f824b190301d9889d0cfe5d746a9a7edd3b19ad003ee70c5f6cc9a26403ec961826462f5e5509a2e12f8a6a99d851fc97b1e46f44e59294aca2
diff --git a/app-admin/awscli/awscli-1.29.68.ebuild b/app-admin/awscli/awscli-1.29.68.ebuild
new file mode 100644
index 000000000000..941051349113
--- /dev/null
+++ b/app-admin/awscli/awscli-1.29.68.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.7.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken xdist (signal() works only in main thread)
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py::TestHelpPager::test_can_handle_ctrl_c
+ tests/unit/test_help.py::TestHelpPager::test_can_render_contents
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignore
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -p xdist -n "$(makeopts_jobs)"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}